Can't set a replication factor for some hidden indices


I can't seem to change a replication factor for some hidden indices:


curl -X PUT "x.x.x.x:9200/.*/_settings" -H 'Content-Type: application/json' -d'{ "index" : { "number_of_replicas" : 2 } }'

affects only .elastichq index, other two keep the same replication factor 1

health status index                                                         uuid                   pri rep docs.count docs.deleted store.size
green  open   .ds-.logs-deprecation.elasticsearch-default-2023.08.01-000017 ffEIhEmISlm66_OOFZMlvQ   1   1        111            0    140.7kb         70.3kb
green  open   .ds-ilm-history-5-2023.08.01-000016                           8aAiHp7YRl-8w_77ockRuw   1   1         18            0     45.4kb         22.6kb
green  open   .elastichq                                                    aDkgWHjaSfKiCAZ_60_2nw   1   2          1            0     27.5kb          6.8kb

Check the _settings on those 2 indices, my guess is that they both have "auto_expand_replicas": "0-1" set which will override the number_of_replicas value you are trying to set. You will need to remove/unset that setting for the indices to increase replicas to 2, etc.

Thanks, so I can modify "auto_expand_replicas": "false".

Can I directly set replication factor for all future .ilm system indexes? As ilm keeps creating new indexes every X days or can I disable creation of .ilm indexes completely? So far I tried to turn off ilm but it doesn't allow me to remove the existing index.


"auto_expand_replicas": null

I can confirm that auto_expand_replicas override number_of_replicas. So I can expand # of replicas by setting auto_expand_replicas i.e. to "0-2".

If I have new .ilm indexes created can you point me where to set auto_expand_replicas for all new future indexes?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.