Can't start Kibana getting FATAL RangeError: out of range index


(Ailson Forte) #1

Getting the following after try start Kibana 6.4.2 with $KIBANA_PATH/bin/kibana (config file only with elasticsearch.url: 'http://127.0.0.1:9200') on Ubuntu Trusty server (kernel 4.15.0-32-generic)

 error  [14:21:59.585] [fatal] RangeError: out of range index
    at fill_ (buffer.js:851:18)
    at Buffer.fill (buffer.js:801:3)
    at Object.<anonymous> (/opt/kibana/node_modules/tar-stream/pack.js:15:12)
    at Module._compile (module.js:652:30)
    at Module._extensions..js (module.js:663:10)
    at Object.require.extensions.(anonymous function) [as .js] (/opt/kibana/node_modules/babel-register/lib/node.js:152:7)
    at Module.load (module.js:565:32)
    at tryModuleLoad (module.js:505:12)
    at Function.Module._load (module.js:497:3)
    at Module.require (module.js:596:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/opt/kibana/node_modules/tar-stream/index.js:2:16)
    at Module._compile (module.js:652:30)
    at Module._extensions..js (module.js:663:10)
    at Object.require.extensions.(anonymous function) [as .js] (/opt/kibana/node_modules/babel-register/lib/node.js:152:7)
    at Module.load (module.js:565:32)
    at tryModuleLoad (module.js:505:12)
    at Function.Module._load (module.js:497:3)
    at Module.require (module.js:596:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/opt/kibana/node_modules/tar-fs/index.js:1:11)
    at Module._compile (module.js:652:30)
    at Module._extensions..js (module.js:663:10)
    at Object.require.extensions.(anonymous function) [as .js] (/opt/kibana/node_modules/babel-register/lib/node.js:152:7)
    at Module.load (module.js:565:32)
    at tryModuleLoad (module.js:505:12)
    at Function.Module._load (module.js:497:3)
    at Module.require (module.js:596:17)
FATAL RangeError: out of range index
    at fill_ (buffer.js:851:18)
    at Buffer.fill (buffer.js:801:3)
    at Object.<anonymous> (/opt/kibana/node_modules/tar-stream/pack.js:15:12)
    at Module._compile (module.js:652:30)
    at Module._extensions..js (module.js:663:10)
    at Object.require.extensions.(anonymous function) [as .js] (/opt/kibana/node_modules/babel-register/lib/node.js:152:7)
    at Module.load (module.js:565:32)
    at tryModuleLoad (module.js:505:12)
    at Function.Module._load (module.js:497:3)
    at Module.require (module.js:596:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/opt/kibana/node_modules/tar-stream/index.js:2:16)
    at Module._compile (module.js:652:30)
    at Module._extensions..js (module.js:663:10)
    at Object.require.extensions.(anonymous function) [as .js] (/opt/kibana/node_modules/babel-register/lib/node.js:152:7)
    at Module.load (module.js:565:32)
    at tryModuleLoad (module.js:505:12)
    at Function.Module._load (module.js:497:3)
    at Module.require (module.js:596:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/opt/kibana/node_modules/tar-fs/index.js:1:11)
    at Module._compile (module.js:652:30)
    at Module._extensions..js (module.js:663:10)
    at Object.require.extensions.(anonymous function) [as .js] (/opt/kibana/node_modules/babel-register/lib/node.js:152:7)
    at Module.load (module.js:565:32)
    at tryModuleLoad (module.js:505:12)
    at Function.Module._load (module.js:497:3)
    at Module.require (module.js:596:17)

(Tyler Smalley) #2

Do you have any plugins installed which could be causing this? Can you re-try downloading from https://www.elastic.co/downloads/kibana?


(Ailson Forte) #3

Have no plugin installed...
I'm installing using the latest download file cause I'm using a script to deploy.

The script:

#!/bin/bash

set -e
version=6.4.2
TEMP_DIR=/opt
KIBANA_INSTALL=${TEMP_DIR}/kibana
download_url=https://artifacts.elastic.co/downloads/kibana/kibana-$version-linux-x86_64.tar.gz
elk_user=elk

wget $download_url
sudo tar -xzvf kibana-$version-linux-x86_64.tar.gz -C $TEMP_DIR

sudo mv $KIBANA_INSTALL-$version* $KIBANA_INSTALL 

cd $KIBANA_INSTALL

elastic_url=http://127.0.0.1:9200

sudo mkdir $KIBANA_INSTALL/logs

sudo touch $KIBANA_INSTALL/logs/kibana.log

sudo chown -R $elk_user:$elk_user $KIBANA_INSTALL

echo -e "$(sudo cat $KIBANA_INSTALL/config/kibana.yml)\nelasticsearch.url: '${elastic_url}'\nlogging.verbose: true" | sudo tee $KIBANA_INSTALL/config/kibana.yml

cat << EOF | sudo tee /lib/systemd/system/kibana.service
[Unit]
Description=Kibana service
After=elasticsearch.service
StartLimitIntervalSec=5

[Service]
Type=simple
Restart=always
RestartSec=1
User=$elk_user
ExecStart=$KIBANA_INSTALL/bin/kibana -l $KIBANA_INSTALL/logs/kibana.log

[Install]
WantedBy=multi-user.target
EOF

sudo systemctl daemon-reload
sudo systemctl enable kibana.service
sudo systemctl start kibana.service


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.