Cardinality Aggregation - NoSuchMethodError


(Robert Douglas) #1

Hi All,

I recently upgraded my ElasticSearch cluster to 1.1.0 in order to utilize
the built in cardinality aggregation. However, whenever I try to run any
sort of cardinality aggregation, I get back:

{

  • error: SearchPhaseExecutionException[Failed to execute phase
    [query_fetch], all shards failed; shardFailures
    {[QOCVDBG8QrCX8arlUl6gGg][w2o_tweet][0]:
    RemoteTransportException[[customsearch-elastic-dev-2][inet[/10.146.214.50:9300]][search/phase/query+fetch]];
    nested:
    ElasticsearchException[org.elasticsearch.common.util.BigArrays.newObjectArray(JLorg/elasticsearch/cache/recycler/PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    nested:
    NoSuchMethodError[org.elasticsearch.common.util.BigArrays.newObjectArray(JLorg/elasticsearch/cache/recycler/PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    }]
  • status: 500

}

My query looks like this:

{
"size": 0,
"query": {
"filtered": {
"query": {
"match_all": {}
},
"filter": {
"and": {
"filters": [
{
"range": {
"tweet.created_at": {
"from": 1392613200000,
"to": 1396843199999,
"include_lower": true,
"include_upper": true
},
"_cache": true
}
}
]
}
}
}
},
"aggs": {
"congress_unique": {
"filter": {
"term": {
"user.screen_name": "CongPalazzo"
}
},
"aggs": {
"unique": {
"cardinality": {
"field": "entities.hashtags.text"
}
}
}
}
}
}

I've checked my mappings and everything looks like it should be good to go.
Any ideas?

Thanks,
Robert

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Alexander Reelsen) #2

Hey,

are you sure that every node has been upgraded to 1.1.0? Looks as if there
is still a 1.0 node running from the outside...

--Alex

On Mon, Apr 7, 2014 at 9:35 PM, Robert Douglas robertd89@gmail.com wrote:

Hi All,

I recently upgraded my ElasticSearch cluster to 1.1.0 in order to utilize
the built in cardinality aggregation. However, whenever I try to run any
sort of cardinality aggregation, I get back:

{

  • error: SearchPhaseExecutionException[Failed to execute phase
    [query_fetch], all shards failed; shardFailures
    {[QOCVDBG8QrCX8arlUl6gGg][w2o_tweet][0]:
    RemoteTransportException[[customsearch-elastic-dev-2][inet[/10.146.214.50:9300]][search/phase/query+fetch]];
    nested:
    ElasticsearchException[org.elasticsearch.common.util.BigArrays.newObjectArray(JLorg/elasticsearch/cache/recycler/PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    nested:
    NoSuchMethodError[org.elasticsearch.common.util.BigArrays.newObjectArray(JLorg/elasticsearch/cache/recycler/PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    }]
  • status: 500

}

My query looks like this:

{
"size": 0,
"query": {
"filtered": {
"query": {
"match_all": {}
},
"filter": {
"and": {
"filters": [
{
"range": {
"tweet.created_at": {
"from": 1392613200000,
"to": 1396843199999,
"include_lower": true,
"include_upper": true
},
"_cache": true
}
}
]
}
}
}
},
"aggs": {
"congress_unique": {
"filter": {
"term": {
"user.screen_name": "CongPalazzo"
}
},
"aggs": {
"unique": {
"cardinality": {
"field": "entities.hashtags.text"
}
}
}
}
}
}

I've checked my mappings and everything looks like it should be good to
go. Any ideas?

Thanks,
Robert

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM_53b5B5GRja1uoBn6cEuCqS04BU2THc2zpnSK%2BqwBoGw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Robert Douglas) #3

Yes, we have two nodes set up in our cluster and I've confirmed that both
of them are running 1.1.0.

However, the error that I'm getting seems to suggest that for some reason
the BigArrays class from 1.0.1 is still being used somewhere. Could that be
caused by an incomplete migration?

-- Robert

On Tuesday, April 8, 2014 4:43:03 AM UTC-5, Alexander Reelsen wrote:

Hey,

are you sure that every node has been upgraded to 1.1.0? Looks as if there
is still a 1.0 node running from the outside...

--Alex

On Mon, Apr 7, 2014 at 9:35 PM, Robert Douglas <robe...@gmail.com<javascript:>

wrote:

Hi All,

I recently upgraded my ElasticSearch cluster to 1.1.0 in order to utilize
the built in cardinality aggregation. However, whenever I try to run any
sort of cardinality aggregation, I get back:

{

  • error: SearchPhaseExecutionException[Failed to execute phase
    [query_fetch], all shards failed; shardFailures
    {[QOCVDBG8QrCX8arlUl6gGg][w2o_tweet][0]:
    RemoteTransportException[[customsearch-elastic-dev-2][inet[/10.146.214.50:9300]][search/phase/query+fetch]];
    nested:
    ElasticsearchException[org.elasticsearch.common.util.BigArrays.newObjectArray(JLorg/elasticsearch/cache/recycler/PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    nested:
    NoSuchMethodError[org.elasticsearch.common.util.BigArrays.newObjectArray(JLorg/elasticsearch/cache/recycler/PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    }]
  • status: 500

}

My query looks like this:

{
"size": 0,
"query": {
"filtered": {
"query": {
"match_all": {}
},
"filter": {
"and": {
"filters": [
{
"range": {
"tweet.created_at": {
"from": 1392613200000,
"to": 1396843199999,
"include_lower": true,
"include_upper": true
},
"_cache": true
}
}
]
}
}
}
},
"aggs": {
"congress_unique": {
"filter": {
"term": {
"user.screen_name": "CongPalazzo"
}
},
"aggs": {
"unique": {
"cardinality": {
"field": "entities.hashtags.text"
}
}
}
}
}
}

I've checked my mappings and everything looks like it should be good to
go. Any ideas?

Thanks,
Robert

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/752a65a1-8f0c-4297-8b16-3e63c7a22fc2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Alexander Reelsen) #4

Hey,

do you use a client node somewhere, which might be the wrong version? Is
this triggered by a HTTP query? What does curl
'10.146.214.50:9200/_cat/nodes?v&jvm'
return?

--Alex

On Tue, Apr 8, 2014 at 4:26 PM, Robert Douglas robertd89@gmail.com wrote:

Yes, we have two nodes set up in our cluster and I've confirmed that both
of them are running 1.1.0.

However, the error that I'm getting seems to suggest that for some reason
the BigArrays class from 1.0.1 is still being used somewhere. Could that be
caused by an incomplete migration?

-- Robert

On Tuesday, April 8, 2014 4:43:03 AM UTC-5, Alexander Reelsen wrote:

Hey,

are you sure that every node has been upgraded to 1.1.0? Looks as if
there is still a 1.0 node running from the outside...

--Alex

On Mon, Apr 7, 2014 at 9:35 PM, Robert Douglas robe...@gmail.com wrote:

Hi All,

I recently upgraded my ElasticSearch cluster to 1.1.0 in order to
utilize the built in cardinality aggregation. However, whenever I try to
run any sort of cardinality aggregation, I get back:

{

  • error: SearchPhaseExecutionException[Failed to execute phase
    [query_fetch], all shards failed; shardFailures
    {[QOCVDBG8QrCX8arlUl6gGg][w2o_tweet][0]: RemoteTransportException[[
    customsearch-elastic-dev-2][inet[/10.146.214.50:9300]][search/phase/query+fetch]];
    nested: ElasticsearchException[org.elasticsearch.common.util.
    BigArrays.newObjectArray(JLorg/elasticsearch/cache/
    recycler/PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    nested: NoSuchMethodError[org.elasticsearch.common.util.
    BigArrays.newObjectArray(JLorg/elasticsearch/cache/
    recycler/PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    }]
  • status: 500

}

My query looks like this:

{
"size": 0,
"query": {
"filtered": {
"query": {
"match_all": {}
},
"filter": {
"and": {
"filters": [
{
"range": {
"tweet.created_at": {
"from": 1392613200000,
"to": 1396843199999,
"include_lower": true,
"include_upper": true
},
"_cache": true
}
}
]
}
}
}
},
"aggs": {
"congress_unique": {
"filter": {
"term": {
"user.screen_name": "CongPalazzo"
}
},
"aggs": {
"unique": {
"cardinality": {
"field": "entities.hashtags.text"
}
}
}
}
}
}

I've checked my mappings and everything looks like it should be good to
go. Any ideas?

Thanks,
Robert

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/752a65a1-8f0c-4297-8b16-3e63c7a22fc2%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/752a65a1-8f0c-4297-8b16-3e63c7a22fc2%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM8bjqBThWtKZLFdWrWj055M8hhM97dJPBemjs8izr27xg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Robert Douglas) #5

How do you mean client node? There are only two nodes currently in this
cluster, a single master and a single worker node. This error is being
triggered by an HTTP query that I'm executing via the head plugin (in the
'Any Request' tab). The results of that curl command are:

curl -XGET
'http://customsearch-elastic-dev-1.customsearch.w2odata.com:9200/_cat/nodes?v&jvm'

host ip heap.percent
ram.percent load node.role master name

customsearch-elastic-dev-1.customsearch.w2odata.com 127.0.1.1 81
65 0.58 d * customsearch-elastic-dev-1

customsearch-elastic-dev-2.customsearch.w2odata.com 127.0.1.1 80
66 0.40 d m customsearch-elastic-dev-2

-- Robert

On Tuesday, April 8, 2014 10:01:19 AM UTC-5, Alexander Reelsen wrote:

Hey,

do you use a client node somewhere, which might be the wrong version? Is
this triggered by a HTTP query? What does curl '10.146.214.50:9200/_cat/nodes?v&jvm'
return?

--Alex

On Tue, Apr 8, 2014 at 4:26 PM, Robert Douglas <robe...@gmail.com<javascript:>

wrote:

Yes, we have two nodes set up in our cluster and I've confirmed that both
of them are running 1.1.0.

However, the error that I'm getting seems to suggest that for some reason
the BigArrays class from 1.0.1 is still being used somewhere. Could that be
caused by an incomplete migration?

-- Robert

On Tuesday, April 8, 2014 4:43:03 AM UTC-5, Alexander Reelsen wrote:

Hey,

are you sure that every node has been upgraded to 1.1.0? Looks as if
there is still a 1.0 node running from the outside...

--Alex

On Mon, Apr 7, 2014 at 9:35 PM, Robert Douglas robe...@gmail.comwrote:

Hi All,

I recently upgraded my ElasticSearch cluster to 1.1.0 in order to
utilize the built in cardinality aggregation. However, whenever I try to
run any sort of cardinality aggregation, I get back:

{

  • error: SearchPhaseExecutionException[Failed to execute phase
    [query_fetch], all shards failed; shardFailures
    {[QOCVDBG8QrCX8arlUl6gGg][w2o_tweet][0]: RemoteTransportException[[
    customsearch-elastic-dev-2][inet[/10.146.214.50:9300]][search/phase/query+fetch]];
    nested: ElasticsearchException[org.elasticsearch.common.util.
    BigArrays.newObjectArray(JLorg/elasticsearch/cache/
    recycler/PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    nested: NoSuchMethodError[org.elasticsearch.common.util.
    BigArrays.newObjectArray(JLorg/elasticsearch/cache/
    recycler/PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    }]
  • status: 500

}

My query looks like this:

{
"size": 0,
"query": {
"filtered": {
"query": {
"match_all": {}
},
"filter": {
"and": {
"filters": [
{
"range": {
"tweet.created_at": {
"from": 1392613200000,
"to": 1396843199999,
"include_lower": true,
"include_upper": true
},
"_cache": true
}
}
]
}
}
}
},
"aggs": {
"congress_unique": {
"filter": {
"term": {
"user.screen_name": "CongPalazzo"
}
},
"aggs": {
"unique": {
"cardinality": {
"field": "entities.hashtags.text"
}
}
}
}
}
}

I've checked my mappings and everything looks like it should be good to
go. Any ideas?

Thanks,
Robert

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/752a65a1-8f0c-4297-8b16-3e63c7a22fc2%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/752a65a1-8f0c-4297-8b16-3e63c7a22fc2%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ffdc1b78-0447-479d-bc76-c5bb4a98f762%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Alexander Reelsen) #6

Hey,

sorry, wrong command, please try: curl 'localhost:9200/_cat/nodes?v&h=j,v'

--Alex

On Tue, Apr 8, 2014 at 5:07 PM, Robert Douglas robertd89@gmail.com wrote:

How do you mean client node? There are only two nodes currently in this
cluster, a single master and a single worker node. This error is being
triggered by an HTTP query that I'm executing via the head plugin (in the
'Any Request' tab). The results of that curl command are:

curl -XGET '
http://customsearch-elastic-dev-1.customsearch.w2odata.com:9200/_cat/nodes?v&jvm
'

host ip heap.percent
ram.percent load node.role master name

customsearch-elastic-dev-1.customsearch.w2odata.com 127.0.1.1
81 65 0.58 d * customsearch-elastic-dev-1

customsearch-elastic-dev-2.customsearch.w2odata.com 127.0.1.1
80 66 0.40 d m customsearch-elastic-dev-2

-- Robert

On Tuesday, April 8, 2014 10:01:19 AM UTC-5, Alexander Reelsen wrote:

Hey,

do you use a client node somewhere, which might be the wrong version? Is
this triggered by a HTTP query? What does curl '10.146.214.50:9200/_cat/nodes?v&jvm'
return?

--Alex

On Tue, Apr 8, 2014 at 4:26 PM, Robert Douglas robe...@gmail.com wrote:

Yes, we have two nodes set up in our cluster and I've confirmed that
both of them are running 1.1.0.

However, the error that I'm getting seems to suggest that for some
reason the BigArrays class from 1.0.1 is still being used somewhere. Could
that be caused by an incomplete migration?

-- Robert

On Tuesday, April 8, 2014 4:43:03 AM UTC-5, Alexander Reelsen wrote:

Hey,

are you sure that every node has been upgraded to 1.1.0? Looks as if
there is still a 1.0 node running from the outside...

--Alex

On Mon, Apr 7, 2014 at 9:35 PM, Robert Douglas robe...@gmail.comwrote:

Hi All,

I recently upgraded my ElasticSearch cluster to 1.1.0 in order to
utilize the built in cardinality aggregation. However, whenever I try to
run any sort of cardinality aggregation, I get back:

{

  • error: SearchPhaseExecutionException[Failed to execute phase
    [query_fetch], all shards failed; shardFailures
    {[QOCVDBG8QrCX8arlUl6gGg][w2o_tweet][0]: RemoteTransportException[[
    customsearch-elastic-dev-2][inet[/10.146.214.50:9300]][search/phase/query+fetch]];
    nested: ElasticsearchException[org.elasticsearch.common.util.
    BigArrays.newObjectArray(JLorg/elasticsearch/cache/recycler/
    PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    nested: NoSuchMethodError[org.elasticsearch.common.util.BigArrays.
    newObjectArray(JLorg/elasticsearch/cache/recycler/
    PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;]; }]
  • status: 500

}

My query looks like this:

{
"size": 0,
"query": {
"filtered": {
"query": {
"match_all": {}
},
"filter": {
"and": {
"filters": [
{
"range": {
"tweet.created_at": {
"from": 1392613200000,
"to": 1396843199999,
"include_lower": true,
"include_upper": true
},
"_cache": true
}
}
]
}
}
}
},
"aggs": {
"congress_unique": {
"filter": {
"term": {
"user.screen_name": "CongPalazzo"
}
},
"aggs": {
"unique": {
"cardinality": {
"field": "entities.hashtags.text"
}
}
}
}
}
}

I've checked my mappings and everything looks like it should be good
to go. Any ideas?

Thanks,
Robert

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40goo
glegroups.comhttps://groups.google.com/d/msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/752a65a1-8f0c-4297-8b16-3e63c7a22fc2%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/752a65a1-8f0c-4297-8b16-3e63c7a22fc2%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ffdc1b78-0447-479d-bc76-c5bb4a98f762%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ffdc1b78-0447-479d-bc76-c5bb4a98f762%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM_2AugnNR8gKaGdynLtuVWmJsP7cK347vEwYUqsPgeb0Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Robert Douglas) #7

curl -XGET
'http://customsearch-elastic-dev-1.customsearch.w2odata.com:9200/_cat/nodes?v&h=j,v'

j v

1.7.0_51 1.1.0

1.7.0_51 1.1.0

On Tuesday, April 8, 2014 10:11:02 AM UTC-5, Alexander Reelsen wrote:

Hey,

sorry, wrong command, please try: curl 'localhost:9200/_cat/nodes?v&h=j,v'

--Alex

On Tue, Apr 8, 2014 at 5:07 PM, Robert Douglas <robe...@gmail.com<javascript:>

wrote:

How do you mean client node? There are only two nodes currently in this
cluster, a single master and a single worker node. This error is being
triggered by an HTTP query that I'm executing via the head plugin (in the
'Any Request' tab). The results of that curl command are:

curl -XGET '
http://customsearch-elastic-dev-1.customsearch.w2odata.com:9200/_cat/nodes?v&jvm
'

host ip
heap.percent ram.percent load node.role master name

customsearch-elastic-dev-1.customsearch.w2odata.com 127.0.1.1
81 65 0.58 d * customsearch-elastic-dev-1

customsearch-elastic-dev-2.customsearch.w2odata.com 127.0.1.1
80 66 0.40 d m customsearch-elastic-dev-2

-- Robert

On Tuesday, April 8, 2014 10:01:19 AM UTC-5, Alexander Reelsen wrote:

Hey,

do you use a client node somewhere, which might be the wrong version? Is
this triggered by a HTTP query? What does curl '10.146.214.50:9200/_cat/nodes?v&jvm'
return?

--Alex

On Tue, Apr 8, 2014 at 4:26 PM, Robert Douglas robe...@gmail.comwrote:

Yes, we have two nodes set up in our cluster and I've confirmed that
both of them are running 1.1.0.

However, the error that I'm getting seems to suggest that for some
reason the BigArrays class from 1.0.1 is still being used somewhere. Could
that be caused by an incomplete migration?

-- Robert

On Tuesday, April 8, 2014 4:43:03 AM UTC-5, Alexander Reelsen wrote:

Hey,

are you sure that every node has been upgraded to 1.1.0? Looks as if
there is still a 1.0 node running from the outside...

--Alex

On Mon, Apr 7, 2014 at 9:35 PM, Robert Douglas robe...@gmail.comwrote:

Hi All,

I recently upgraded my ElasticSearch cluster to 1.1.0 in order to
utilize the built in cardinality aggregation. However, whenever I try to
run any sort of cardinality aggregation, I get back:

{

  • error: SearchPhaseExecutionException[Failed to execute phase
    [query_fetch], all shards failed; shardFailures
    {[QOCVDBG8QrCX8arlUl6gGg][w2o_tweet][0]:
    RemoteTransportException[[customsearch-elastic-dev-2][inet[/
    10.146.214.50:9300]][search/phase/query+fetch]]; nested:
    ElasticsearchException[org.elasticsearch.common.util.BigArra
    ys.newObjectArray(JLorg/elasticsearch/cache/recycler/
    PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    nested: NoSuchMethodError[org.elasticsearch.common.util.BigArrays.
    newObjectArray(JLorg/elasticsearch/cache/recycler/
    PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    }]
  • status: 500

}

My query looks like this:

{
"size": 0,
"query": {
"filtered": {
"query": {
"match_all": {}
},
"filter": {
"and": {
"filters": [
{
"range": {
"tweet.created_at": {
"from": 1392613200000,
"to": 1396843199999,
"include_lower": true,
"include_upper": true
},
"_cache": true
}
}
]
}
}
}
},
"aggs": {
"congress_unique": {
"filter": {
"term": {
"user.screen_name": "CongPalazzo"
}
},
"aggs": {
"unique": {
"cardinality": {
"field": "entities.hashtags.text"
}
}
}
}
}
}

I've checked my mappings and everything looks like it should be good
to go. Any ideas?

Thanks,
Robert

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40goo
glegroups.comhttps://groups.google.com/d/msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/752a65a1-8f0c-4297-8b16-3e63c7a22fc2%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/752a65a1-8f0c-4297-8b16-3e63c7a22fc2%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ffdc1b78-0447-479d-bc76-c5bb4a98f762%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ffdc1b78-0447-479d-bc76-c5bb4a98f762%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1055b798-7f6e-4199-9d5d-b82be18f69af%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Robert Douglas) #8

j v

1.7.0_51 1.1.0

1.7.0_51 1.1.0

On Tuesday, April 8, 2014 10:11:02 AM UTC-5, Alexander Reelsen wrote:

Hey,

sorry, wrong command, please try: curl 'localhost:9200/_cat/nodes?v&h=j,v'

--Alex

On Tue, Apr 8, 2014 at 5:07 PM, Robert Douglas <robe...@gmail.com<javascript:>

wrote:

How do you mean client node? There are only two nodes currently in this
cluster, a single master and a single worker node. This error is being
triggered by an HTTP query that I'm executing via the head plugin (in the
'Any Request' tab). The results of that curl command are:

curl -XGET '
http://customsearch-elastic-dev-1.customsearch.w2odata.com:9200/_cat/nodes?v&jvm
'

host ip
heap.percent ram.percent load node.role master name

customsearch-elastic-dev-1.customsearch.w2odata.com 127.0.1.1
81 65 0.58 d * customsearch-elastic-dev-1

customsearch-elastic-dev-2.customsearch.w2odata.com 127.0.1.1
80 66 0.40 d m customsearch-elastic-dev-2

-- Robert

On Tuesday, April 8, 2014 10:01:19 AM UTC-5, Alexander Reelsen wrote:

Hey,

do you use a client node somewhere, which might be the wrong version? Is
this triggered by a HTTP query? What does curl '10.146.214.50:9200/_cat/nodes?v&jvm'
return?

--Alex

On Tue, Apr 8, 2014 at 4:26 PM, Robert Douglas robe...@gmail.comwrote:

Yes, we have two nodes set up in our cluster and I've confirmed that
both of them are running 1.1.0.

However, the error that I'm getting seems to suggest that for some
reason the BigArrays class from 1.0.1 is still being used somewhere. Could
that be caused by an incomplete migration?

-- Robert

On Tuesday, April 8, 2014 4:43:03 AM UTC-5, Alexander Reelsen wrote:

Hey,

are you sure that every node has been upgraded to 1.1.0? Looks as if
there is still a 1.0 node running from the outside...

--Alex

On Mon, Apr 7, 2014 at 9:35 PM, Robert Douglas robe...@gmail.comwrote:

Hi All,

I recently upgraded my ElasticSearch cluster to 1.1.0 in order to
utilize the built in cardinality aggregation. However, whenever I try to
run any sort of cardinality aggregation, I get back:

{

  • error: SearchPhaseExecutionException[Failed to execute phase
    [query_fetch], all shards failed; shardFailures
    {[QOCVDBG8QrCX8arlUl6gGg][w2o_tweet][0]:
    RemoteTransportException[[customsearch-elastic-dev-2][inet[/
    10.146.214.50:9300]][search/phase/query+fetch]]; nested:
    ElasticsearchException[org.elasticsearch.common.util.BigArra
    ys.newObjectArray(JLorg/elasticsearch/cache/recycler/
    PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    nested: NoSuchMethodError[org.elasticsearch.common.util.BigArrays.
    newObjectArray(JLorg/elasticsearch/cache/recycler/
    PageCacheRecycler;)Lorg/elasticsearch/common/util/ObjectArray;];
    }]
  • status: 500

}

My query looks like this:

{
"size": 0,
"query": {
"filtered": {
"query": {
"match_all": {}
},
"filter": {
"and": {
"filters": [
{
"range": {
"tweet.created_at": {
"from": 1392613200000,
"to": 1396843199999,
"include_lower": true,
"include_upper": true
},
"_cache": true
}
}
]
}
}
}
},
"aggs": {
"congress_unique": {
"filter": {
"term": {
"user.screen_name": "CongPalazzo"
}
},
"aggs": {
"unique": {
"cardinality": {
"field": "entities.hashtags.text"
}
}
}
}
}
}

I've checked my mappings and everything looks like it should be good
to go. Any ideas?

Thanks,
Robert

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40goo
glegroups.comhttps://groups.google.com/d/msgid/elasticsearch/3f6d4148-ede7-48ab-a213-3bde272b515b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/752a65a1-8f0c-4297-8b16-3e63c7a22fc2%
40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/752a65a1-8f0c-4297-8b16-3e63c7a22fc2%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ffdc1b78-0447-479d-bc76-c5bb4a98f762%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/ffdc1b78-0447-479d-bc76-c5bb4a98f762%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8dbbc9c7-deb6-40c8-9c57-039deade7e78%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #9