Case (lower and upper) issue with TermsFacetBuilder result


(Chetana) #1

I am using the 'term facet' functionality of ElasticSearch 0.90.2 on a
paticular field (datatype). The field (datatype) stores one of the enum
values in camel case (example : sampleType). I am using a standard analyzer
for index and search which internally uses lowercase filter. The strange
thing is that when I get the results for facets. I get 2 counts. One with
lowercase and the other with camel case. Is there any workaround for this ?

The facet result looks like :

"facets" : {

"datatype" : {

"_type" : "terms",

"missing" : 5,

"total" : 62,

"other" : 0,

"terms" : [ {

"term" : "sampletype",

"count" : 30

}, {

"term" : "sampleType",

"count" : 20

}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/caf5a9d3-e5e5-417b-bf71-e6340d8e14cb%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Chetana) #2

I have observed this behavior on Ubantu 11.10 version.

On Wednesday, January 15, 2014 10:29:41 AM UTC+5:30, Chetana wrote:

I am using the 'term facet' functionality of ElasticSearch 0.90.2 on a
paticular field (datatype). The field (datatype) stores one of the enum
values in camel case (example : sampleType). I am using a standard analyzer
for index and search which internally uses lowercase filter. The strange
thing is that when I get the results for facets. I get 2 counts. One with
lowercase and the other with camel case. Is there any workaround for this ?

The facet result looks like :

"facets" : {

"datatype" : {

"_type" : "terms",

"missing" : 5,

"total" : 62,

"other" : 0,

"terms" : [ {

"term" : "sampletype",

"count" : 30

}, {

"term" : "sampleType",

"count" : 20

}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/02c6e23c-b947-449d-a09d-9567a34e764b%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3