Caused by: java.util.ServiceConfigurationError: jakarta.json.spi.JsonProvider: Provider org.eclipse.parsson.JsonProviderImpl not a subtype

I am using ElasticSearch Java Client API 8.3.2.
In my application, I need to load the Elasticsearch related jars using classloaders.

I have the below set of jars to be loaded in order. Everytime I get the error as below:
Caused by: java.util.ServiceConfigurationError: jakarta.json.spi.JsonProvider: Provider org.eclipse.parsson.JsonProviderImpl not a subtype

elasticsearch-java-8.3.2.jar
elasticsearch-rest-client-8.3.2.jar
commons-fileupload-1.3.1.jar
commons-io-2.4.jar
dms.jar
ojdbc7.jar
jackson-core-asl-1.9.2.jar
jackson-jaxrs-1.9.2.jar
jackson-mapper-asl-1.9.2.jar
jackson-xc-1.9.2.jar
jersey-client-1.19.1.jar
jersey-core-1.19.1.jar
jersey-json-1.19.1.jar
jersey-server-1.19.1.jar
jersey-servlet-1.19.1.jar
jettison-1.1.jar
jsr311-api-1.1.1.jar
json-simple-1.1.jar
json-simple-1.1.jar
slf4j-api-1.7.9.jar
slf4j-simple-1.7.9.jar
log4j-1.2.14.jar
httpclient-4.5.13.jar
httpcore-4.4.14.jar
httpasyncclient-4.1.4.jar
httpcore-nio-4.4.14.jar
commons-codec-1.15.jar
commons-logging-1.2.jar
jsr305-3.0.2.jar
jackson-databind-2.12.3.jar
jackson-annotations-2.13.0.jar
jackson-core-2.13.0.jar
jakarta.json-api-2.0.1.jar

Please advise.