Ccs_minimize_roundtrips error when using 7.X high level REST API to access 6.x index

I am using Elastic Search High Level REST API 7.x and try to access ES 6.7 index and go the following error:
ElasticsearchStatusException[Elasticsearch exception [type=illegal_argument_exception, reason=request [xxxxxxxx] contains unrecognized parameter: [ccs_minimize_roundtrips]]]
If I downgrade the API to 6.x, then the error disappears. The problem is that I have to access both 7.x and 6.x index using the REST API. So, ideally, using 7.x API should be backward compatible with 6.x. But this is not the case. Is there any concern using 6.8.1 API to access 7.x ES index?

Any advise is appreciated.

our high-level REST client is forward compatible, meaning that you can use a 6.x client against 7.x nodes. But once you use the 7.x client, is will use the options that are known to be supported on 7.x nodes. If you want to talk both to 6.x and 7.x using the same client, you should use the 6.x high-level client. The downside of this is that you are giving up on any new feature that 7.x may support (like minimizing roundtrips in CCS for instance).

Also, we recommend when upgrading to upgrade the client last.

This is all mentioned in our docs here: .

Thanks Luca.
I am using 6.8 REST API with 7.2 ES lib now. But got another error which reported on

Any advice? Thanks

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.