Cert error for intial setup of fileBeat

I've followed the documention to connect client with filebeat to elasticsearch : Filebeat quick start: installation and configuration | Filebeat Reference [8.7] | Elastic

My filebeat.yml

# ---------------------------- Elasticsearch Output ----------------------------
  # Array of hosts to connect to.
  hosts: ["myip:9200"]

  # Protocol - either `http` (default) or `https`.
  protocol: "https"

  # Authentication credentials - either API key or username/password.
  #api_key: "id:api_key"
  username: "elastic"
  password: "mypassword"
    enabled: true
    ca_trusted_fingerprint: ""

For the ca_trusted_fingerprint, I use the followed command find in the documentation on my elasticsearch machine with the following output

/etc/elasticsearch/certs# openssl x509 -fingerprint -sha256 -in /etc/elasticsearch/certs/http_ca.crt
sha256 Fingerprint=03:57:5A:6B:8E:C5:C1:C8:FA:8B:66:6D:B4:2D:36:E6:65:AB:C5:C2:4C:14:37:16:8E:11:7E:CD:CF:6A:17:10

I've pasted the fingerprint in filebeat.yml
Then I run the filebeat setup and this append

sudo filebeat setup
Exiting: couldn't connect to any of the configured Elasticsearch hosts. Errors: [error connecting to Elasticsearch at https://myip:9200: Get "https://myip:9200": decode 'ca_trusted_fingerprint': encoding/hex: invalid byte: U+003A ':']

Now i'm stuck..
Can you provide help ?

Hi @Nibort Welcome to the community!

I see you solved your issue... Perhaps you could post you solution as it may help other users.

Hey can you provide the solution for this problem if your issue is resolved?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.