Change elasticsearch.yml and now ES will not run


#1

Okay - have had a single node working (ES5.5) for a week or so using network.host as 127.0.0.1, indexing and pushing responses to queries without a problem until today.

Today I wanted to allow access from another machine so changed network.host to:

network.host: ['127.0.0.1', '192.168.0.5']

and ES will not run.

It starts up, but 15 - 17 seconds later it dies, no log files given!

Any ideas why this may be happening? I comment out the network.host line and it runs fine again..........very confused!

Thanks


(Ramkrishna P) #2

What does the ES console show?


(David Pilato) #3

Can you try:

network.host: ["127.0.0.1", "192.168.0.5"]

#4

rkpotdar - please see below. I missed the log file with this in that shows bootstrap checks are failing......not sure what that means so Google hunting I will go!

dadoonet - tried but same result unfortunately.

[2017-09-11T13:52:53,987][WARN ][o.e.b.JNANatives ] Unable to lock JVM Memory: error=12, reason=Cannot allocate memory
[2017-09-11T13:52:53,990][WARN ][o.e.b.JNANatives ] This can result in part of the JVM being swapped out.
[2017-09-11T13:52:53,990][WARN ][o.e.b.JNANatives ] Increase RLIMIT_MEMLOCK, soft limit: 65536, hard limit: 65536
[2017-09-11T13:52:53,990][WARN ][o.e.b.JNANatives ] These can be adjusted by modifying /etc/security/limits.conf, for example:
# allow user 'elasticsearch' mlockall
elasticsearch soft memlock unlimited
elasticsearch hard memlock unlimited
[2017-09-11T13:52:53,991][WARN ][o.e.b.JNANatives ] If you are logged in interactively, you will have to re-login for the new limits to take effect.
[2017-09-11T13:52:54,318][INFO ][o.e.n.Node ] [hash-1] initializing ...
[2017-09-11T13:52:54,563][INFO ][o.e.e.NodeEnvironment ] [hash-1] using [1] data paths, mounts [[/ (/dev/loop1)]], net usable_space [10.7gb], net total_space [29.4gb], spins? [possibly], types [ext4]
[2017-09-11T13:52:54,564][INFO ][o.e.e.NodeEnvironment ] [hash-1] heap size [1.9gb], compressed ordinary object pointers [true]
[2017-09-11T13:52:54,589][INFO ][o.e.n.Node ] [hash-1] node name [hash-1], node ID [G3HvJKb-RsmHAkvCnYkMEw]
[2017-09-11T13:52:54,589][INFO ][o.e.n.Node ] [hash-1] version[5.5.2], pid[511], build[b2f0c09/2017-08-14T12:33:14.154Z], OS[Linux/4.10.17-2-pve/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/1.8.0_131/25.131-b11]
[2017-09-11T13:52:54,589][INFO ][o.e.n.Node ] [hash-1] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -Djdk.io.permissionsUseCanonicalPath=true, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j.skipJansi=true, -XX:+HeapDumpOnOutOfMemoryError, -Des.path.home=/usr/share/elasticsearch]
[2017-09-11T13:52:57,182][INFO ][o.e.p.PluginsService ] [hash-1] loaded module [aggs-matrix-stats]
[2017-09-11T13:52:57,182][INFO ][o.e.p.PluginsService ] [hash-1] loaded module [ingest-common]
[2017-09-11T13:52:57,182][INFO ][o.e.p.PluginsService ] [hash-1] loaded module [lang-expression]
[2017-09-11T13:52:57,182][INFO ][o.e.p.PluginsService ] [hash-1] loaded module [lang-groovy]
[2017-09-11T13:52:57,182][INFO ][o.e.p.PluginsService ] [hash-1] loaded module [lang-mustache]
[2017-09-11T13:52:57,182][INFO ][o.e.p.PluginsService ] [hash-1] loaded module [lang-painless]
[2017-09-11T13:52:57,182][INFO ][o.e.p.PluginsService ] [hash-1] loaded module [parent-join]
[2017-09-11T13:52:57,182][INFO ][o.e.p.PluginsService ] [hash-1] loaded module [percolator]
[2017-09-11T13:52:57,182][INFO ][o.e.p.PluginsService ] [hash-1] loaded module [reindex]
[2017-09-11T13:52:57,183][INFO ][o.e.p.PluginsService ] [hash-1] loaded module [transport-netty3]
[2017-09-11T13:52:57,183][INFO ][o.e.p.PluginsService ] [hash-1] loaded module [transport-netty4]
[2017-09-11T13:52:57,183][INFO ][o.e.p.PluginsService ] [hash-1] no plugins loaded
[2017-09-11T13:53:01,235][INFO ][o.e.d.DiscoveryModule ] [hash-1] using discovery type [zen]
[2017-09-11T13:53:02,575][INFO ][o.e.n.Node ] [hash-1] initialized
[2017-09-11T13:53:02,590][INFO ][o.e.n.Node ] [hash-1] starting ...
[2017-09-11T13:53:02,969][INFO ][o.e.t.TransportService ] [hash-1] publish_address {192.168.0.5:9300}, bound_addresses {127.0.0.1:9300}, {192.168.0.5:9300}
[2017-09-11T13:53:02,982][INFO ][o.e.b.BootstrapChecks ] [hash-1] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
[2017-09-11T13:53:03,002][ERROR][o.e.b.Bootstrap ] [hash-1] node validation exception
[2] bootstrap checks failed
[1]: memory locking requested for elasticsearch process but memory is not locked
[2]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
[2017-09-11T13:53:03,043][INFO ][o.e.n.Node ] [hash-1] stopping ...
[2017-09-11T13:53:03,133][INFO ][o.e.n.Node ] [hash-1] stopped
[2017-09-11T13:53:03,133][INFO ][o.e.n.Node ] [hash-1] closing ...
[2017-09-11T13:53:03,152][INFO ][o.e.n.Node ] [hash-1] closed


(Ramkrishna P) #5

I suspect that your transport.host is only the localhost while the network.host has both local and a new IP. Could you try adding this new IP to transport.host?


#6

Thanks for the suggestions above guys - had a dig about on the bootstrap tests and found an extra line I had to add into the elasticsearch.yml file to get it working after adding an 'external' IP:

discovery.type: single-node

Now stays up and is working!

Appreciate the fast replies as well - thanks!


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.