Change remplica number in elasticsearch templates (Beats/Logstash/ES setup)

Hi there,
I am new to Elasticsearch and I currently have a setup with a number of machines with beats installed (filebeat and metricbeat), outputting to logstash, which in turn outputs to my single ES node. As I only have one node I would like to set my replica count to 0 (or set auto expand to true).
Looking at past answers, I'm confused as to where I should be modifying the template, on my logstash or for each metricbeat? I've tried adding setup.template.settings to my metricbeat configuration but it didn't work. What's more if that is the right way to do it, what would happen if different beats had different replication settings (since currently they write to the same daily index (metricbeat-6.8.5-*).
Thanks for your help,

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.