Changing codec for existing indexes


(Neha Sharma) #1

We are upgrading our ES version to 6.4.2 and would set default compression to best_comrpession. Problem is that when restoring index from a snapshot, the best-compression is not applied even when explicitly setting codec for that index.

How can I compress my existing index?


(Christian Dahlqvist) #2

Set the codec to best_compression for the index and the run a force merge down to a single segment. This will apply the new codec.


(Neha Sharma) #3

Thanks!


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.