Changing NON Dynamic setting of allready created index


(Amish) #1

Hi
We have an index with setting like :

curl -XGET 'http://localhost:9200//_settings' -d '{
...
"analysis" : {
"filter" : {
"truncate_filter" : {
"type" : "truncate",
"length" : "7000"
},
....
}

Now we want to change the length of the truncate filter setting without
recreating the index.

When we tried to change the setting it gives error:
error": "ElasticsearchIllegalArgumentException[Can't update non dynamic
settings.....

This one can understand.

Then we went ahead and did the following:
a) Close the index
b) Again changed the setting to something smaller say 5000. It went
through fine.
c) Open the index and checked the setting. It shows the new setting as 5000
and as far as we can see it works fine.

Question : What exactly happened here. I am assuming it has not changed
anything for the existing data, but is using this setting only for new
data. Is this a bug or intended behaviour or just a workaround which we
should not use.

regards and thanks
amish

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7a8761ff-de25-40cd-8cac-5e32a35ee158%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2