Changing the workers number

I'm trying to define transactions with elapsed filter, and I got the "elapsed_end_without_start" tag.
I found that the same issue happens to other people and the solution that has been suggested is changing the workers number to 1.
It needs to be changed in the logstach.yml or pipelines.yml?
How can I know that it's has been changed?
I have tried to change them both and nothing happens...

You can change it for all pipelines using either the command line or logstash.yml. You can change it for individual pipelines using pipelines.yml.

Thanks for the quick response.
I run this command line: bin\logstash -w 1
and nothing has been changed (I think, how can I check that?) and the problem with the elapsed_end_without_start.
How should it look in logstash.yml?

Thank you again!

In logstash.yml, try setting

pipeline.java_execution: false

There is a PR to fix this issue in-flight.

Should I just add it to the logstash.yml? there aren't these settings:

Unfortunately it is still not working for me, and I get "elapsed_end_without_start" tag. any ideas what can I do?

No, I can't think of anything else.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.