checkIndex wit ES 1.1.0


(Michael Salmon) #1

I recently had a problem with an index and after searching the net I decided to give checkIndex a try. I found the class in the right jar but I haven't been able to get it to check an index. For example when I run

checkIndex -verbose ...heat-analyzer/7/index

I get:

ERROR: could not read any segments file in directory
java.io.FileNotFoundException: ...heat-analyzer/7/index/segments_37l (No such file or directory)

That is correct, the directory contains:

_checksums-1397035754356 _j85h_es090_0.blm _j8fu.cfe _j91a.cfs
_isy5.nvm _j86v.cfe _j8g4.cfs _j95w_es090_0.tim
_j821.si _j870.cfs _j8hl.si _j963.si
_j82l.cfs _j898_Lucene45_0.dvd _j8ln.cfs _j968.cfs
_j838.cfe _j8ap.cfe _j8t6.cfe _j975.si
_j83a.fdx _j8b6.cfs _j8tb_es090_0.doc _j9b9.cfs
_j83o.nvd _j8c1.si _j8tp.cfs _j9di_es090_0.blm
_j83o.si _j8cz.si _j8v9.fnm _j9e0.cfe
_j83p.nvd _j8et.cfs _j8yv.cfe segments.gen
_j84u.cfs _j8fa.cfs _j919.fdt write.lock

I am running ES 1.1.0 and using the checkIndex from Lucene 4.7.0.

Has anyone gotten checkIndex to work with this combination?

/Michael

This space intentionally left not blank.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0CB7B85A-8ADE-4943-A912-1689411FEFF2%40inovia.nu.
For more options, visit https://groups.google.com/d/optout.


(Adrien Grand) #2

Hi Michael,

Running checkindex from the command line can prove to be tricky, since
checkindex is not aware of things like multi-data-path directories that you
might be using with Elasticsearch. Moreover, you will need to add the
Elasticsearch jars to the classpath since Elasticsearch customizes some of
the index file formats.

Elasticsearch has the ability to run checkindex when opening an index, see
index.shard.check_on_startup[1]. When set to true, Elasticsearch will run
checkindex when opening indices and prevent them from being open if they
appear to be corrupted. In case of a failure, you will need to check out
the logs in order to have details. Please not that this is not a live
setting, so this can only be changed on a closed index.

[1]
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules.html#index-modules-settings

On Wed, Apr 9, 2014 at 11:37 AM, Michael Salmon michael.salmon@inovia.nuwrote:

I recently had a problem with an index and after searching the net I
decided to give checkIndex a try. I found the class in the right jar but I
haven't been able to get it to check an index. For example when I run

checkIndex -verbose ...heat-analyzer/7/index

I get:

ERROR: could not read any segments file in directory
java.io.FileNotFoundException: ...heat-analyzer/7/index/segments_37l (No
such file or directory)

That is correct, the directory contains:

_checksums-1397035754356 _j85h_es090_0.blm _j8fu.cfe
_j91a.cfs
_isy5.nvm _j86v.cfe _j8g4.cfs
_j95w_es090_0.tim
_j821.si _j870.cfs _j8hl.si _
j963.si
_j82l.cfs _j898_Lucene45_0.dvd _j8ln.cfs
_j968.cfs
_j838.cfe _j8ap.cfe _j8t6.cfe _
j975.si
_j83a.fdx _j8b6.cfs _j8tb_es090_0.doc
_j9b9.cfs
_j83o.nvd _j8c1.si _j8tp.cfs
_j9di_es090_0.blm
_j83o.si _j8cz.si _j8v9.fnm
_j9e0.cfe
_j83p.nvd _j8et.cfs _j8yv.cfe
segments.gen
_j84u.cfs _j8fa.cfs _j919.fdt
write.lock

I am running ES 1.1.0 and using the checkIndex from Lucene 4.7.0.

Has anyone gotten checkIndex to work with this combination?

/Michael

This space intentionally left not blank.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/0CB7B85A-8ADE-4943-A912-1689411FEFF2%40inovia.nu
.
For more options, visit https://groups.google.com/d/optout.

--
Adrien Grand

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAL6Z4j6A_khwE4MY3XT%3D%3DB3JMVY5%2BDCJfJuafanCiZDtF16epw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3