Cluster Nodes are not reflecting

We were using elasticsearch with only 1 node i.e. ES01 which also have log data of almost 2 weeks. Now we are trying to expand to 3 nodes with additional 2 servers i.e. ES02 & ES03, configured yml files on these 2 servers with same cluster name and parameters. Defining ES01 & ES03 as data node and ES02 as master node. But when we checking through "GET /_cluster/state?pretty" only ES02 node is reflecting, other 2 nodes are not reflecting.

Also checked through cluster logs, getting below error :
Caused by: java.lang.IllegalStateException: failure when sending a validation request to node
Caused by: org.elasticsearch.transport.RemoteTransportException: [es-01][][internal:cluster/coordination/join/validate]
Caused by: org.elasticsearch.cluster.coordination.CoordinationStateRejectedException: join validation on cluster state with a different cluster uuid 6dNKxAyJQOWO-fB2jKK8GA than local cluster uuid bHr4ENdkT0yt92UWGhDLYw, rejecting

Can you please check and let me know what is the resolution of this error/issue ?

can anyone suggest on this issue ?

1st on a 3 node cluster you should make all 3 data plus master that much better configuration, not just 1 master. In fact if you are just learning just leave the default node roles.

On ES01 elasticsearch.yml originally did you set or is it still set?

discovery.type : single-node

If so it will not join the other the other nodes and now you have 2 separate clusters? That is what log says 2 cluster UUIDs.

If you did you will need to clean out the ED02/03 get the settings right and then restart.

You should read this it tells about cleaning up and getting the cluster bootstrapped

We have also enable XPACK on all 3 nodes, generated passwords from ES02 but the same credentials not able to run curl command. In short, how to configure 3 node cluster if XPACK is enable ?

I think you need to refer to the documentation.

XPack is a lot of things , perhaps you are talking about security
See here

here is how to form a cluster.

You really need to go about this in a methodical way.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.