Cluster.routing.allocation.cluster_concurrent_rebalance not respected?


(Georgi Ivanov) #1

Hi,
In elasticsearch.yml i have :
cluster.routing.allocation.cluster_concurrent_rebalance : 6

still i see

curl http://localhost:9200/_cat/health?v
epoch timestamp cluster status node.total node.data shards pri
relo init unassign
1399991043 16:24:03 mycluster green 8 8 676 338
2 0 0

Number of relocating shards sometimes goes up to 3 , but i never see it
goes to 6

Am i missing something here ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0589a8ad-5352-4ecf-8b56-faeb10ef78a6%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

I might be misreading this, but as far as I know spacing matters in the yml
config. Try - cluster.routing.allocation.cluster_concurrent_rebalance: 2

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 14 May 2014 00:27, Georgi Ivanov georgi.r.ivanov@gmail.com wrote:

Hi,
In elasticsearch.yml i have :
cluster.routing.allocation.cluster_concurrent_rebalance : 6

still i see

curl http://localhost:9200/_cat/health?v
epoch timestamp cluster status node.total node.data shards
pri relo init unassign
1399991043 16:24:03 mycluster green 8 8 676
338 2 0 0

Number of relocating shards sometimes goes up to 3 , but i never see it
goes to 6

Am i missing something here ?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/0589a8ad-5352-4ecf-8b56-faeb10ef78a6%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/0589a8ad-5352-4ecf-8b56-faeb10ef78a6%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624YT%3DG-yfcF7d%2BW7GOLFs%2BhdtbmCx9xScMSvQ%2BitkuTyNA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3