Cluster setup with ELK 5.0.1


(sayalee) #1

I was trying to create a cluster with 3 nodes having ELK 5.0 on Redhat server

The following are the steps which I have followed:

• I have used Ansible and Tinc VPN for security purpose.

• Binded to my VPN IP (192.168.0.1, 192.168.0.2 and 192.168.0.3) in /etc/elasticsearch/elasticsearch.yml by editing the network.host to my VPN interface name “tun0”
as network.host: [tun0, local].

• Set cluster name and node name for each node, but when I am trying to start the service elasticsearch it is getting locked by showing the error, but when I am editing the network.host with localhost its working fine.

These are the logs for Elasticsearch, please have a look at it.

[2016-11-18T12:03:11,258][INFO ][o.e.n.Node ] [node03] stopping ...
[2016-11-18T12:03:13,075][INFO ][o.e.n.Node ] [node03] stopped
[2016-11-18T12:03:13,076][INFO ][o.e.n.Node ] [node03] closing ...
[2016-11-18T12:03:13,338][INFO ][o.e.n.Node ] [node03] closed
[2016-11-18T12:03:24,081][WARN ][o.e.b.JNANatives ] unable to install syscall filter:
java.lang.UnsupportedOperationException: seccomp unavailable: CONFIG_SECCOMP not compiled into kernel, CONFIG_SECCOMP and CONFIG_SECCOMP_FILTER are needed
at org.elasticsearch.bootstrap.Seccomp.linuxImpl(Seccomp.java:361) ~[elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.bootstrap.Seccomp.init(Seccomp.java:630) ~[elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.bootstrap.JNANatives.trySeccomp(JNANatives.java:215) [elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.bootstrap.Natives.trySeccomp(Natives.java:99) [elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:101) [elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:155) [elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:286) [elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:112) [elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:103) [elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) [elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:96) [elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.cli.Command.main(Command.java:62) [elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80) [elasticsearch-5.0.0.jar:5.0.0]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:73) [elasticsearch-5.0.0.jar:5.0.0]
max number of threads [1024] for user [elasticsearch] likely too low, increase to at least [2048]
[2016-11-18T12:03:33,569][INFO ][o.e.n.Node ] [node03] stopping ...
[2016-11-18T12:03:33,624][INFO ][o.e.n.Node ] [node03] stopped
[2016-11-18T12:03:33,625][INFO ][o.e.n.Node ] [node03] closing ...
[2016-11-18T12:03:33,649][INFO ][o.e.n.Node ] [node03] closed

But when I tried the same with elasticsearch 2.3.5 it worked,please can anyone let me know what is the problem.
[This is the link which I followed for clustering]

(https://www.digitalocean.com/community/tutorials/how-to-set-up-a-production-elasticsearch-cluster-on-ubuntu-14-04)


(Magnus Bäck) #2

I suppose ES 2.3.5 doesn't require CONFIG_SECCOMP or care about the max number of threads.


(sayalee) #4

Can you please let me know that is there any solution, if we need to do it on ELK 5.0.


(sayalee) #5

I tried the same (clustering) with latest version 5.0.2, thinking that the bug might have been solved but the issue is same, can someone please help me to solve the same.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.