Cluster yellow state


(flyer) #1

I have a cluster of two nodes and have the following configs for shards and
replicas:

index.number_of_shards: 10

index.number_of_replicas: 1

But when I index around 10k data or just one data, I find that there are
always 4 replica shards not to be allocated.

Is there a method to allocate all replica shards on the two nodes? Thanks
in advance.

--
宠辱不惊,闲看庭前花开花落;去留无意,漫随天边云卷云舒。

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKLbBG-%2BKobeupzPhOiF0FZ9Lf0eeWsBOotLEd%2B_v4arR%3DzHwA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

Try removing the replicas and then readding them.
You can also force allocation -
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-allocation.html

  • but the first option is an easier one to start with.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 6 June 2014 09:35, flyer flyer103@gmail.com wrote:

I have a cluster of two nodes and have the following configs for shards
and replicas:

index.number_of_shards: 10

index.number_of_replicas: 1

But when I index around 10k data or just one data, I find that there are
always 4 replica shards not to be allocated.

Is there a method to allocate all replica shards on the two nodes? Thanks
in advance.

--
宠辱不惊,闲看庭前花开花落;去留无意,漫随天边云卷云舒。

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKLbBG-%2BKobeupzPhOiF0FZ9Lf0eeWsBOotLEd%2B_v4arR%3DzHwA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKLbBG-%2BKobeupzPhOiF0FZ9Lf0eeWsBOotLEd%2B_v4arR%3DzHwA%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624ZQny1Uy2RwKJ%2BRYi0hLexjFv2%2B8E8jkZccQpsqLrKong%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(flyer) #3

Because it's difficult to recognize which shards are replica (I haven't
installed the head plugin), I removed all of the index data, tried to
reindex the data but got the same results that there were still some
replica shards not to be allocated.

I want to know why there're some replica not to be allocated.

"shard allocation filter" seems troublesome. So is there another way to
solve this problem other than using shard allocation filter?

On Fri, Jun 6, 2014 at 7:57 AM, Mark Walkom markw@campaignmonitor.com
wrote:

Try removing the replicas and then readding them.
You can also force allocation -
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-allocation.html

  • but the first option is an easier one to start with.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 6 June 2014 09:35, flyer flyer103@gmail.com wrote:

I have a cluster of two nodes and have the following configs for shards
and replicas:

index.number_of_shards: 10

index.number_of_replicas: 1

But when I index around 10k data or just one data, I find that there are
always 4 replica shards not to be allocated.

Is there a method to allocate all replica shards on the two nodes? Thanks
in advance.

--
宠辱不惊,闲看庭前花开花落;去留无意,漫随天边云卷云舒。

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKLbBG-%2BKobeupzPhOiF0FZ9Lf0eeWsBOotLEd%2B_v4arR%3DzHwA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKLbBG-%2BKobeupzPhOiF0FZ9Lf0eeWsBOotLEd%2B_v4arR%3DzHwA%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEM624ZQny1Uy2RwKJ%2BRYi0hLexjFv2%2B8E8jkZccQpsqLrKong%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEM624ZQny1Uy2RwKJ%2BRYi0hLexjFv2%2B8E8jkZccQpsqLrKong%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
宠辱不惊,闲看庭前花开花落;去留无意,漫随天边云卷云舒。

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKLbBG9MwJ4xNhouWmOUAhj3B5%3DNujcOSsRvChmYyOL-k3POYA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(flyer) #4

I add another node into the cluster and now after I index data, the state
of the cluster becomes green.

If the replica number is 1, must I have at least 3 nodes to assure that the
state of the cluster is green?

On Fri, Jun 6, 2014 at 9:46 AM, flyer flyer103@gmail.com wrote:

Because it's difficult to recognize which shards are replica (I haven't
installed the head plugin), I removed all of the index data, tried to
reindex the data but got the same results that there were still some
replica shards not to be allocated.

I want to know why there're some replica not to be allocated.

"shard allocation filter" seems troublesome. So is there another way to
solve this problem other than using shard allocation filter?

On Fri, Jun 6, 2014 at 7:57 AM, Mark Walkom markw@campaignmonitor.com
wrote:

Try removing the replicas and then readding them.
You can also force allocation -
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-allocation.html

  • but the first option is an easier one to start with.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 6 June 2014 09:35, flyer flyer103@gmail.com wrote:

I have a cluster of two nodes and have the following configs for
shards and replicas:

index.number_of_shards: 10

index.number_of_replicas: 1

But when I index around 10k data or just one data, I find that there are
always 4 replica shards not to be allocated.

Is there a method to allocate all replica shards on the two nodes?
Thanks in advance.

--
宠辱不惊,闲看庭前花开花落;去留无意,漫随天边云卷云舒。

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKLbBG-%2BKobeupzPhOiF0FZ9Lf0eeWsBOotLEd%2B_v4arR%3DzHwA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKLbBG-%2BKobeupzPhOiF0FZ9Lf0eeWsBOotLEd%2B_v4arR%3DzHwA%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEM624ZQny1Uy2RwKJ%2BRYi0hLexjFv2%2B8E8jkZccQpsqLrKong%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEM624ZQny1Uy2RwKJ%2BRYi0hLexjFv2%2B8E8jkZccQpsqLrKong%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
宠辱不惊,闲看庭前花开花落;去留无意,漫随天边云卷云舒。

--
宠辱不惊,闲看庭前花开花落;去留无意,漫随天边云卷云舒。

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKLbBG-WZZABmG9Ts%3DmbJfjAbMspHDjSSEsTL8C8Yjm3qxxDcg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(flyer) #5

It's caused by different versions of ES. In my previous test, one node use
ES-1.1.1 and the other uses ES-1.1.2. After every node of the cluster uses
the same version of ES, then the first problem disappears.

Thank you very much!

On Fri, Jun 6, 2014 at 11:46 AM, flyer flyer103@gmail.com wrote:

I add another node into the cluster and now after I index data, the state
of the cluster becomes green.

If the replica number is 1, must I have at least 3 nodes to assure that
the state of the cluster is green?

On Fri, Jun 6, 2014 at 9:46 AM, flyer flyer103@gmail.com wrote:

Because it's difficult to recognize which shards are replica (I haven't
installed the head plugin), I removed all of the index data, tried to
reindex the data but got the same results that there were still some
replica shards not to be allocated.

I want to know why there're some replica not to be allocated.

"shard allocation filter" seems troublesome. So is there another way to
solve this problem other than using shard allocation filter?

On Fri, Jun 6, 2014 at 7:57 AM, Mark Walkom markw@campaignmonitor.com
wrote:

Try removing the replicas and then readding them.
You can also force allocation -
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-allocation.html

  • but the first option is an easier one to start with.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 6 June 2014 09:35, flyer flyer103@gmail.com wrote:

I have a cluster of two nodes and have the following configs for
shards and replicas:

index.number_of_shards: 10

index.number_of_replicas: 1

But when I index around 10k data or just one data, I find that there
are always 4 replica shards not to be allocated.

Is there a method to allocate all replica shards on the two nodes?
Thanks in advance.

--
宠辱不惊,闲看庭前花开花落;去留无意,漫随天边云卷云舒。

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKLbBG-%2BKobeupzPhOiF0FZ9Lf0eeWsBOotLEd%2B_v4arR%3DzHwA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKLbBG-%2BKobeupzPhOiF0FZ9Lf0eeWsBOotLEd%2B_v4arR%3DzHwA%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEM624ZQny1Uy2RwKJ%2BRYi0hLexjFv2%2B8E8jkZccQpsqLrKong%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEM624ZQny1Uy2RwKJ%2BRYi0hLexjFv2%2B8E8jkZccQpsqLrKong%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
宠辱不惊,闲看庭前花开花落;去留无意,漫随天边云卷云舒。

--
宠辱不惊,闲看庭前花开花落;去留无意,漫随天边云卷云舒。

--
宠辱不惊,闲看庭前花开花落;去留无意,漫随天边云卷云舒。

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKLbBG8C9FwazZH0GEgdfRKXEKz2FCaOfDk5xt14%3DwFowieEcQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #6