Completion Suggester Foreign Language Accents Greek


(Björn Grambow) #1

Hi,

I am trying to use the Completion suggester with Greek language. Unfortunately I have problems with accents like ά. I've tried a few ways.

One was simply to set the greek analyzer in the mapping the other a lowercase analyzer with asciifolding. No success, with greek analyser I dont even get a result with the accent.

Below is what I did, hope someone can help me out here ... Thanks.

Mapping

PUT t1
{
  "mappings": {
    "profession" : {
      "properties" : {
        "text" : {
            "type" : "keyword"
        },
        "suggest" : {
            "type" : "completion",
            "analyzer": "greek"
        }
      }
    }
  }
}

Dummy

POST t1/profession/?refresh
{
    "suggest" : {
        "input": [ "Μάγειρας"]
    }
    ,"text": "Μάγειρας"
}

Query

GET t1/profession/_search
{ "suggest": 
  { "profession" : 
      { "prefix" : "Μα"
      , "completion" : 
        { "field" : "suggest"}
      }}}

(Björn Grambow) #2

I found a way to do it with a custom analyzer. See below. It would be great though to figure out why the build in greek analyzer doesn't work

    PUT t1
    { "settings": 
        { "analysis": 
          { "filter": 
            { "greek_lowercase": 
              { "type":       "lowercase"
              , "language":   "greek"
              }  
            }
          , "analyzer": 
              { "autocomplete": 
                { "tokenizer": "lowercase"
                , "filter": 
                    [ "greek_lowercase" ]
              }
            }
        }}
    , "mappings": {
        "profession" : {
          "properties" : {
            "text" : {
                "type" : "keyword"
            },
            "suggest" : {
                "type" : "completion",
                "analyzer": "autocomplete"
            }
          }}}
    }

(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.