Config language = no (Norwegian) problems


(Barsk) #1

When using the ICU filter like this:

index :
analysis :
analyzer :
myCollation :
type : custom
tokenizer : standard
filter : [myCollator]
filter :
myCollator :
type : icu_collation
language : no

The language is interpreted as "false" when the code
String language = settings.get("language");
is run inside IcuCollationTokenFilterFactory. I ran this in debug mode
to check. The parser for the config settings converts the string "no" to
"false" when it is expected to be passed as "no" (= Norwegian).

I guess we can call this a bug :wink:

/Kristian

--
Med vänlig hälsning
Kristian Jörg

Devo IT AB
Tel: 054 - 22 14 58, 0709 - 15 83 42
E-post: kristian.jorg@devo.se
Webb: http://www.devo.se


(Barsk) #2

Created an issue for this as:

Kristian Jörg skrev 2011-02-16 13:37:

When using the ICU filter like this:

index :
analysis :
analyzer :
myCollation :
type : custom
tokenizer : standard
filter : [myCollator]
filter :
myCollator :
type : icu_collation
language : no

The language is interpreted as "false" when the code
String language = settings.get("language");
is run inside IcuCollationTokenFilterFactory. I ran this in debug mode
to check. The parser for the config settings converts the string "no"
to "false" when it is expected to be passed as "no" (= Norwegian).

I guess we can call this a bug :wink:

/Kristian


(system) #3