Configure filebeat nginx module with ansible role

Dear experts,

Can you please lead me into the right direction how I have to customize the GitHub - elastic/ansible-beats: Ansible Beats Role role so that the nginx module is enabled and working?

Thanks and br,
Elmar

I got it installed properly meanwhile, however I am now getting error:

Failed to connect to backoff(elasticsearch(https://*.eu-central-1.es.amazonaws.com:443/)): Connection marked as failed because the onConnect callback failed: cannot retrieve the elasticsearch license from the /_license endpoint, Filebeat requires the default distribution of Elasticsearch. Please make the endpoint accessible to Filebeat so it can verify the license.: unauthorized access, could not connect to the xpack endpoint, verify your credentials

It seems to be the problem described in this post Filebeat doesn't work with AWS ES domain (oss version of filebeat has to be used) so now my question is is it possible to customize GitHub - elastic/ansible-beats: Ansible Beats Role so that the oss version is installed?

Thanks and br,
Elmar

Hey @elster,

In theory this is supported, take a look to this change: Allow use oss repository by robsonpeixoto · Pull Request #61 · elastic/ansible-beats · GitHub

1 Like

Thanks, finally I got the oss version installed by uninstalling the original version first and then setting variable oss_version: true.

1 Like