Configure MySQL module


#1

Per Configure the MySQL module

# cat mysql.yml 
- module: mysql
  # Error logs
  error:
    enabled: true

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    var.paths: ["/var/log/mysql/error.log*"]

  # Slow logs
  slowlog:
    enabled: true

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    #var.paths:
# ls -ld /var/log/mysql/error.log* | head -1
-rw-r----- 1 mysql adm 2472 Feb 21 16:47 /var/log/mysql/error.log
# 

however whenever I open Filebeat MySQL Dashboard via Kibana, I get

No results found

Please advise.


(Adrian Serrano) #2

What is your output configuration? Are you sending directly to Elasticsearch?

Did you configure the Default Index Pattern in Kibana? are you looking at the filebeat indices? Did you check in the Time Filter that your selected range contains events?

Run filebeat with debug logs enabled, to confirm that it is publishing events: filebeat run -e -d publish


#3

I should have included that information from the beginning:

mysql -> filebeat -> logstash -> elasticsearch -> kibana

# filebeat test output
logstash: logstash:5044...
  connection...
    parse host... OK
    dns lookup... OK
    addresses: 10.X.X.X
    dial up... OK
  TLS... WARN secure connection disabled
  talk to server... OK
# 

I do see events inside of filebeat-6.2.1-2018.02.21 with following filter:

{
  "query": {
    "match": {
      "fileset.module": {
        "query": "mysql",
        "type": "phrase"
      }
    }
  }
}

yet not in Kibana's Dashboard/Visualization...


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.