Configuration of Filebeat Modules


(Milad Hamid) #1

Hi,

After enabling Apache2, and Mysql modules with filebeat 6.1 on windows, i didn't get any data on Kibana and dashboards.

Maybe my configuration is missed something, to ship logs by using modules. Please check my filebeat.yml:

#Filebeat prospectors
filebeat.prospectors:
-type: log
enabled: false
paths:
#- C:\xampp\mysql\data\mysql_error.log
#- C:\xampp\apache\logs\error.log
#- C:\xampp\apache\logs\access.log
#Filebeat modules
filebeat.config.modules:
#Glob pattern for configuration loading
#path: ${path.config}/modules.d/*.yml
#path: C:\Filebeat6\filebeat-6.1.1-windows-x86_64\modules.d*.yml
#path: $ C:\Filebeat6\filebeat-6.1.1-windows-x86_64\modules.d*.yml
filebeat.modules:
-module: mysql
-module: apache2
reload.enabled: false

#Kibana
setup.kibana:
host: "localhost:5601"
#Elasticsearch output
output.elasticsearch:
hosts: ["localhost:9200"]

Actaully i don't know how to define Glob pattern for configuration loading in filebeat modules section.


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.