Configuring TLS and authentication in Local

Hi All,
I am following below blog for TLS configutation on my local windows machine.

After completing and following till step 3 when I am running second elasticsearch node its giving below error.While first master node is running fine.

Please suggest what to do.

Caused by: java.lang.IllegalArgumentException: can't add node {RENLTP2N022}{7a-f3ebMRn6qVx0b7DXo2A}{g9QImwYeTBm8umV9QQx6ag}{}{}{di}{ml.machine_memory=17080250368, ml.max_open_jobs=20, xpack.installed=true}, found existing node {RENLTP2N022}{7a-f3ebMRn6qVx0b7DXo2A}{ZaYmlK-5TfCSPG6RNYyQbw}{}{}{dim}{ml.machine_memory=17080250368, xpack.installed=true, ml.max_open_jobs=20} with the same id but is a different node instance
at org.elasticsearch.cluster.node.DiscoveryNodes$Builder.add( ~[elasticsearch-7.3.2.jar:7.3.2]


As far as I know, the ElasticSearch Node ID is generated at the first start of the instance and persisted in the data directory of ElasticSearch.

What Operating System are you on and how did you install it(downloaded the zip-file)? My guess is that you copied the ElasticSearch installation containing the data directory with the node id into a new location for the second node. As the node found the node id in the data directory it did not create a new one => id conflict.

Best regards

Thanks @Wolfram_Haussig
Yes i am working on windows machine..and i copied entire config folder thats why issue was after copying certain files only(not complete folder) issue is resolved..
Both ES nodes are running at 9200 and 9201 ports.Is this the way to test that TLS is enabled or there is any other way?

Also please suggest what are the steps(documentation) to configure TLS on Cloud using Helm.I did not got any straight forward link



I think there is nothing wrong with the way you want to check TLS. Regarding TLS on Cloud: I have no experience with Cloud in general and Helm in particular but I am sure there are others here that can help you.

Best regards

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.