Confirming mlockall is working?

Hey,
I've noticed some request time spikes with 0.16.2 that I hadn't
observed with 0.14.2. I know that mlockall was critical in ensuring
that GC didn't have much hit on response times.

The docs state that:
In order to see if this works or not, set the common.jna logging to
DEBUG level. A solution to “Unknown mlockall error 0” can be to set
ulimit -l unlimited.

I have set common.jna logging to DEBUG, but don't see any messages
logged from this class. Is that a confirmation that mlockall is
working or should I expect to see something indicating that it is
working?

Thanks!
Paul

Yes, if you don't see anything in the lock, then it should be working.

On Wed, Jul 27, 2011 at 7:46 PM, ppearcy ppearcy@gmail.com wrote:

Hey,
I've noticed some request time spikes with 0.16.2 that I hadn't
observed with 0.14.2. I know that mlockall was critical in ensuring
that GC didn't have much hit on response times.

The docs state that:
In order to see if this works or not, set the common.jna logging to
DEBUG level. A solution to “Unknown mlockall error 0” can be to set
ulimit -l unlimited.

I have set common.jna logging to DEBUG, but don't see any messages
logged from this class. Is that a confirmation that mlockall is
working or should I expect to see something indicating that it is
working?

Thanks!
Paul

Hi,

I had the same worries about whether my mlockall setting was actually
set, would it be possible to put a positive message in the logs like
"mlockall now working"?

Best Regards,

David.

On Jul 27, 6:01 pm, Shay Banon kim...@gmail.com wrote:

Yes, if you don't see anything in the lock, then it should be working.

On Wed, Jul 27, 2011 at 7:46 PM, ppearcy ppea...@gmail.com wrote:

Hey,
I've noticed some request time spikes with 0.16.2 that I hadn't
observed with 0.14.2. I know that mlockall was critical in ensuring
that GC didn't have much hit on response times.

The docs state that:
In order to see if this works or not, set the common.jna logging to
DEBUG level. A solution to “Unknown mlockall error 0” can be to set
ulimit -l unlimited.

I have set common.jna logging to DEBUG, but don't see any messages
logged from this class. Is that a confirmation that mlockall is
working or should I expect to see something indicating that it is
working?

Thanks!
Paul

Yes, I think it makes sense. Something like, if its explicitly set, then log
a warn if its not working. Can you open an issue for it?

On Mon, Aug 1, 2011 at 2:56 PM, davrob2 daviroberts@gmail.com wrote:

Hi,

I had the same worries about whether my mlockall setting was actually
set, would it be possible to put a positive message in the logs like
"mlockall now working"?

Best Regards,

David.

On Jul 27, 6:01 pm, Shay Banon kim...@gmail.com wrote:

Yes, if you don't see anything in the lock, then it should be working.

On Wed, Jul 27, 2011 at 7:46 PM, ppearcy ppea...@gmail.com wrote:

Hey,
I've noticed some request time spikes with 0.16.2 that I hadn't
observed with 0.14.2. I know that mlockall was critical in ensuring
that GC didn't have much hit on response times.

The docs state that:
In order to see if this works or not, set the common.jna logging to
DEBUG level. A solution to “Unknown mlockall error 0” can be to set
ulimit -l unlimited.

I have set common.jna logging to DEBUG, but don't see any messages
logged from this class. Is that a confirmation that mlockall is
working or should I expect to see something indicating that it is
working?

Thanks!
Paul

Issue raise here: https://github.com/elasticsearch/elasticsearch/issues/1194

thanks.

On Aug 1, 9:55 pm, Shay Banon kim...@gmail.com wrote:

Yes, I think it makes sense. Something like, if its explicitly set, then log
a warn if its not working. Can you open an issue for it?

On Mon, Aug 1, 2011 at 2:56 PM, davrob2 davirobe...@gmail.com wrote:

Hi,

I had the same worries about whether my mlockall setting was actually
set, would it be possible to put a positive message in the logs like
"mlockall now working"?

Best Regards,

David.

On Jul 27, 6:01 pm, Shay Banon kim...@gmail.com wrote:

Yes, if you don't see anything in the lock, then it should be working.

On Wed, Jul 27, 2011 at 7:46 PM, ppearcy ppea...@gmail.com wrote:

Hey,
I've noticed some request time spikes with 0.16.2 that I hadn't
observed with 0.14.2. I know that mlockall was critical in ensuring
that GC didn't have much hit on response times.

The docs state that:
In order to see if this works or not, set the common.jna logging to
DEBUG level. A solution to “Unknown mlockall error 0” can be to set
ulimit -l unlimited.

I have set common.jna logging to DEBUG, but don't see any messages
logged from this class. Is that a confirmation that mlockall is
working or should I expect to see something indicating that it is
working?

Thanks!
Paul

I have a noob question here.

where (as in what file, is it etc/init.d/elasticsearch, or /etc/elasticsearch/elasticsearch.yml?) do I set the common.jna, and what is the syntax for setting it to debug?

do I just set
common.jna = DEBUG
next to
bootstrap.mlockall: true
?

Where would I then follow the log to see this? would that be in /var/log/elasticsearch/elasticsearch.log?

when would this appear there, when I start the service ("service elasticsearch start")?