Connect Elastic Search to Tableau - max file descriptors [4096] for elasticsearch process is too low, increase to at least [65535]

Hi ,
I am getting error while running the elastic search after adding below details in elasticsearch.yml
to connect elastic search to Tableau

http.port: 9200
network.host: ["0.0.0.0", 127.0.0.1", "[::1]"]
network.bind_host: 0.0.0.0
network.publish_host: 0.0.0.0
http.host: 0.0.0.0
http.cors.enabled : true
http.cors.allow-origin : "*"
http.cors.allow-methods : OPTIONS, HEAD, GET, POST, PUT, DELETE
http.cors.allow-headers : X-Requested-With,X-Auth-Token,Content-Type, Content-Length

After adding above in was getting below error
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65535]
[2]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

For error reolution , I have configured below
Error 1 - max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
Resolution -
Login as root user and run below command

sysctl -w vm.max_map_count=262144

Error 2 - max file descriptors [4096] for elasticsearch process is too low, increase to at least [65535]
Reslution - Update the configuration file /etc/security/limits.conf
updated below

  soft    nofile    65536
 hard    nofile    65536 

Infra - Its a single ELK cluster installed in AWS EC2 .
When I try to restart the elastic search still getting below error
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65535]

Appreciate the help !!

Thanks,

Please read https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html

I did try this option and set below property

discovery type to single-node

When restarted the elasticsearch it gave me error unknown data / parameter in yml file .

Thanks

I did not mean to bypass the bootstrap checks. I think it's important that you fix the actual problems.
So read https://www.elastic.co/guide/en/elasticsearch/reference/current/_file_descriptor_check.html and its solution here: https://www.elastic.co/guide/en/elasticsearch/reference/current/file-descriptors.html

If you still have an error, please share all the logs.