Connection: close

http://localhost:5601 not success. Please help me

[root@localhost ~]# curl -XGET http://localhost:5601/status -I
HTTP/1.1 200 OK
kbn-name: kibana
kbn-xpack-sig: 7c2d9d868c80e37c5b837fc2ba7d44d3
cache-control: no-cache
content-type: text/html; charset=utf-8
content-length: 67397
accept-ranges: bytes
connection: close

[root@localhost ~]# curl -I http://localhost:9200
HTTP/1.1 200 OK
content-type: application/json; charset=UTF-8
content-length: 493

Hi @Pradeepan,

Could you please share the logs and brief about the problem which you are facing?

Regards,
Harsh Bajaj

HI Thanks to help me ,

Using centos 7.x , installed Elasticsearch and the status is good. And installed Kibana , Status is good , but connection: Close ( It should be keep-alive).

Cannot access kibana from other Host / same host ( [http://localhost:5601]. Question , why the connection is close

Kibana
[root@localhost ~]# curl -XGET http://localhost:5601/status -I
HTTP/1.1 200 OK
kbn-name: kibana
kbn-xpack-sig: 7c2d9d868c80e37c5b837fc2ba7d44d3
cache-control: no-cache
content-type: text/html; charset=utf-8
content-length: 67397
accept-ranges: bytes
connection: close

Elasticsearch
[root@localhost ~]# curl -I http://localhost:9200
HTTP/1.1 200 OK
content-type: application/json; charset=UTF-8
content-length: 493

[root@localhost /]# curl -X GET "localhost:9200"
{
"name" : "5Tv99e8",
"cluster_name" : "elasticsearch",
"cluster_uuid" : "MgTLRih0RiyR3-g-ZugJtQ",
"version" : {
"number" : "6.5.4",
"build_flavor" : "default",
"build_type" : "rpm",
"build_hash" : "d2ef93d",
"build_date" : "2018-12-17T21:17:40.758843Z",
"build_snapshot" : false,
"lucene_version" : "7.5.0",
"minimum_wire_compatibility_version" : "5.6.0",
"minimum_index_compatibility_version" : "5.0.0"
},
"tagline" : "You Know, for Search"
}

Hi @Pradeepan,

Could you please confirm on below points.

1). What happens when you directly ping the URL via curl `curl -XGET 'http://localhost:5601/ ?
2). Please paste your kibana.yml file.
3). please share the logs while starting kibana service.

Please do let me know if any help is required from my end.

Regards,
Harsh Bajaj

Hi Harsh
Kindly find below logs. Note , I am using centos 7 server version.

1). What happens when you directly ping the URL via curl `curl -XGET 'http://localhost:5601/ ?
[root@localhost ~]# curl -XGET 'http://localhost:5601/

2). Please paste your kibana.yml file.
[root@localhost ~]# cat /etc/kibana/kibana.yml

Kibana is served by a back end server. This setting specifies the port to use.

server.port: 5601

Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.

The default is 'localhost', which usually means remote machines will not be able to connect.

To allow connections from remote users, set this parameter to a non-loopback address.

server.host: "localhost"

Enables you to specify a path to mount Kibana at if you are running behind a proxy.

Use the server.rewriteBasePath setting to tell Kibana if it should remove the basePath

from requests it receives, and to prevent a deprecation warning at startup.

This setting cannot end in a slash.

#server.basePath: ""

Specifies whether Kibana should rewrite requests that are prefixed with

server.basePath or require that they are rewritten by your reverse proxy.

This setting was effectively always false before Kibana 6.3 and will

default to true starting in Kibana 7.0.

#server.rewriteBasePath: false

The maximum payload size in bytes for incoming server requests.

#server.maxPayloadBytes: 1048576

The Kibana server's name. This is used for display purposes.

#server.name: "your-hostname"

The URL of the Elasticsearch instance to use for all your queries.

elasticsearch.url: "http://localhost:9200"

When this setting's value is true Kibana uses the hostname specified in the server.host

setting. When the value of this setting is false, Kibana uses the hostname of the host

that connects to this Kibana instance.

#elasticsearch.preserveHost: true

Kibana uses an index in Elasticsearch to store saved searches, visualizations and

dashboards. Kibana creates a new index if the index doesn't already exist.

#kibana.index: ".kibana"

The default application to load.

#kibana.defaultAppId: "home"

If your Elasticsearch is protected with basic authentication, these settings provide

the username and password that the Kibana server uses to perform maintenance on the Kibana

index at startup. Your Kibana users still need to authenticate with Elasticsearch, which

is proxied through the Kibana server.

#elasticsearch.username: "user"
#elasticsearch.password: "pass"

Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.

These settings enable SSL for outgoing requests from the Kibana server to the browser.

#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

Optional settings that provide the paths to the PEM-format SSL certificate and key files.

These files validate that your Elasticsearch backend uses the same key files.

#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

Optional setting that enables you to specify a path to the PEM file for the certificate

authority for your Elasticsearch instance.

#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

To disregard the validity of SSL certificates, change this setting's value to 'none'.

#elasticsearch.ssl.verificationMode: full

Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of

the elasticsearch.requestTimeout setting.

#elasticsearch.pingTimeout: 1500

Time in milliseconds to wait for responses from the back end or Elasticsearch. This value

must be a positive integer.

#elasticsearch.requestTimeout: 30000

List of Kibana client-side headers to send to Elasticsearch. To send no client-side

headers, set this value to (an empty list).

#elasticsearch.requestHeadersWhitelist: [ authorization ]

Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten

by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.

#elasticsearch.customHeaders: {}

Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.

#elasticsearch.shardTimeout: 30000

Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.

#elasticsearch.startupTimeout: 5000

Logs queries sent to Elasticsearch. Requires logging.verbose set to true.

#elasticsearch.logQueries: false

Specifies the path where Kibana creates the process ID file.

#pid.file: /var/run/kibana.pid

Enables you specify a file where Kibana stores log output.

#logging.dest: stdout

Set the value of this setting to true to suppress all logging output.

#logging.silent: false

Set the value of this setting to true to suppress all logging output other than error messages.

#logging.quiet: false

Set the value of this setting to true to log all events, including system usage information

and all requests.

#logging.verbose: false

Set the interval in milliseconds to sample system and process performance

metrics. Minimum is 100ms. Defaults to 5000.

#ops.interval: 5000

Specifies locale to be used for all localizable strings, dates and number formats.

#i18n.locale: "en"
[root@localhost ~]#

Below 3 services are up
server.port: 5601
server.host: "localhost"
elasticsearch.url: "http://localhost:9200"

3). please share the logs while starting kibana service.
[root@localhost ~]# curl -XGET http://localhost:5601/status -I
HTTP/1.1 200 OK
kbn-name: kibana
kbn-xpack-sig: 7c2d9d868c80e37c5b837fc2ba7d44d3
cache-control: no-cache
content-type: text/html; charset=utf-8
content-length: 67397
accept-ranges: bytes
connection: close
Date: Wed, 30 Jan 2019 01:39:09 GMT

[root@localhost ~]#

Connection : close ???????

Hi @Pradeepan

Than you for your response.

I can't see any o/p of this. could you please share the o/p.

Thanks,
Harsh Bajaj

[root@localhost /]# curl -XGET http://localhost:5601/status -I

HTTP/1.1 200 OK

kbn-name: kibana

kbn-xpack-sig: 7c2d9d868c80e37c5b837fc2ba7d44d3

cache-control: no-cache

content-type: text/html; charset=utf-8

content-length: 67397

accept-ranges: bytes

connection: close

Date: Mon, 04 Feb 2019 01:24:00 GMT

[root@localhost /]# curl -X GET "localhost:9200"

{

"name" : "5Tv99e8",

"cluster_name" : "elasticsearch",

"cluster_uuid" : "MgTLRih0RiyR3-g-ZugJtQ",

"version" : {

"number" : "6.5.4",

"build_flavor" : "default",

"build_type" : "rpm",

"build_hash" : "d2ef93d",

"build_date" : "2018-12-17T21:17:40.758843Z",

"build_snapshot" : false,

"lucene_version" : "7.5.0",

"minimum_wire_compatibility_version" : "5.6.0",

"minimum_index_compatibility_version" : "5.0.0"

},

"tagline" : "You Know, for Search"

}

[root@localhost /]# curl -X GET "localhost:5601"

[root@localhost /]# sudo nginx -t

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok

nginx: configuration file /etc/nginx/nginx.conf test is successful

[root@localhost /]# netstat -anp | grep 5601

tcp 0 0 127.0.0.1:5601 0.0.0.0:* LISTEN 5572/node

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:notifications@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uniniti

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:infra@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized",

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:metrics@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["reporting","warning"],"pid":5572,"message":"Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing on restart,

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:reporting@6.5.4","info"],"pid":5572,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","p

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:elasticsearch@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevM

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["license","info","xpack"],"pid":5572,"message":"Imported license information from Elasticsearch for the [data] cluster: mode: basic | status: active"}

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:xpack_main@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg"

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:searchprofiler@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prev

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:ml@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"Waitin

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:tilemap@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"W

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:watcher@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"W

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:index_management@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","pr

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:rollup@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"Wa

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:graph@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"Wai

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:grokdebugger@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMs

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:logstash@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:beats_management@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","pr

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:reporting@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["info","monitoring-ui","kibana-monitoring"],"pid":5572,"message":"Starting monitoring stats collection"}

Feb 04 11:14:12 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:12Z","tags":["status","plugin:security@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"

Feb 04 11:14:13 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:13Z","tags":["license","info","xpack"],"pid":5572,"message":"Imported license information from Elasticsearch for the [monitoring] cluster: mode: basic | status: active"}

Feb 04 11:14:13 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:13Z","tags":["reporting","warning"],"pid":5572,"message":"Enabling the Chromium sandbox provides an additional layer of protection."}
Feb 04 11:14:13 localhost.localdomain kibana[5572]: {"type":"log","@timestamp":"2019-02-04T01:14:13Z","tags":["status","plugin:spaces@6.5.4","info"],"pid":5572,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"Wa
Feb 04 11:25:09 localhost.localdomain kibana[5572]: {"type":"response","@timestamp":"2019-02-04T01:25:09Z","tags":,"pid":5572,"method":"get","statusCode":302,"req":{"url":"/","method":"get","headers":{"user-agent":"curl/7.29.0","host":"localhost:5601","accept":"*/

Hi @Pradeepan,

it seems ok. could you please share the o/p of "curl -X GET "localhost:5601" as i'm not able see anything.

are you getting anything on the screen while running this command.

Regards,
Harsh Bajaj

Hi @harshbajaj16 I'm currently facing the same problem
the result of curl -XGET http://localhost:5601/status -I is:

    HTTP/1.1 200 OK
    kbn-name: kibana
    kbn-xpack-sig: af64802307d39c41399bcb0901d3e850
    cache-control: no-cache
    content-type: text/html; charset=utf-8
    content-length: 67386
    accept-ranges: bytes
    connection: close
    Date: Wed, 06 Feb 2019 11:38:07 GMT

And I'm not getting anything from curl -X GET "localhost:5601"
I'm using the images of docker elasticsearch:6.5.1 and kibana:6.5.1

Regards

But when I send the request to my host
curl -XGET http://myhost.com.co:5601/status -I

I'm getting

        HTTP/1.1 503 Service Temporarily Unavailable
        Server: awselb/2.0
        Date: Wed, 06 Feb 2019 13:37:06 GMT
        Content-Type: text/html
        Content-Length: 178
        Connection: keep-alive

My kibana.yml

        ---
        # Default Kibana configuration from kibana-docker.
        server.name: kibana
        server.host: "0"
        elasticsearch.url: http://elasticsearch:9200
        xpack.monitoring.ui.container.elasticsearch.enabled: true

elasticsearch.yml

         cluster.name: "docker-cluster"
         network.host: 0.0.0.0

        # minimum_master_nodes need to be explicitly set when bound on a public IP
        # set to 1 to allow single node clusters
        # Details: https://github.com/elastic/elasticsearch/pull/17288

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.