Connection error

Hi to All,

When i try to give put request with the below particulars, (In All requesttab in elastic search head)

{
"type": "jdbc",
"jdbc": {
"driver": "com.mysql.jdbc.driver",
"url": "jdbc:mysql://192.168.1.223:3306;databaseName=amwaj",
"user": "root",
"password": "root",
"sql": "select * from account",
"poll": "30s"
},
"index": {
"index": "amwaj",
"type": "account",
"bulk_size": 500
}
}
i am getting the below error,

[ERROR][org.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource]
com.mysql.jdbc.driver
java.lang.ClassNotFoundException: com.mysql.jdbc.driver

Kindly help me out what are things i have to cross check and what i left out

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Add mysql JDBC driver to ES classpath.
Basically, read JDBC river's doc. It's described there.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 16 juil. 2013 à 05:12, signin.vasanth@gmail.com a écrit :

Hi to All,

When i try to give put request with the below particulars, (In All request tab in elastic search head)

{
"type": "jdbc",
"jdbc": {
"driver": "com.mysql.jdbc.driver",
"url": "jdbc:mysql://192.168.1.223:3306;databaseName=amwaj",
"user": "root",
"password": "root",
"sql": "select * from account",
"poll": "30s"
},
"index": {
"index": "amwaj",
"type": "account",
"bulk_size": 500
}
}
i am getting the below error,

[ERROR][org.elasticsearch.river.jdbc.strategy.simple.SimpleRiverSource] com.mysql.jdbc.driver
java.lang.ClassNotFoundException: com.mysql.jdbc.driver

Kindly help me out what are things i have to cross check and what i left out

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.