Connection issue on publishing events on elastic clould


(Kevin Leung) #1

Hi i have following issue when i run the heartbeat with elasticseach clould

All the login name and password is correct but just can't connect to is.
Does anyone know is it some issue on my setting?

2017-05-20T00:31:44+10:00 ERR Connecting error publishing events (retrying): Get https://XXXXXX.ap-southeast-1.aws.found.io:9343: malformed HTTP status code "acceptable"
################### Heartbeat Configuration Example #########################

# This file is an example configuration file highlighting only some common options.
# The heartbeat.full.yml file in the same directory contains all the supported options
# with detailed comments. You can use it for reference.
#
# You can find the full configuration reference here:
# https://www.elastic.co/guide/en/beats/heartbeat/index.html

############################# Heartbeat ######################################

# Configure monitors
heartbeat.monitors:
- type: http

  # List or urls to query
  urls: ["http://www.google.com"]

  # Configure task schedule
  schedule: '@every 10s'

  # Total test connection and data exchange timeout
  #timeout: 16s

#================================ General =====================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
#name:

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#fields:
#  env: staging

#================================ Outputs =====================================

# Configure what outputs to use when sending the data collected by the beat.
# Multiple outputs may be used.

#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["https://XXXXX.ap-southeast-1.aws.found.io:9343"]

  # Optional protocol and basic auth credentials.
  protocol: "https"
  username: "XXXXX"
  password: "XXXXX"

  template.name: "heartbeat"
  template.path: "heartbeat.template.json"
  template.overwrite: false

#----------------------------- Logstash output --------------------------------
#output.logstash:
  # The Logstash hosts
  #hosts: ["localhost:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"

#================================ Logging =====================================

# Sets log level. The default log level is info.
# Available log levels are: critical, error, warning, info, debug
#logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publish", "service".
#logging.selectors: ["*"]

(Steffen Siering) #2

That's weird. Have you tried with HTTP only? Are you sure about the port number? My cloud instance is using port 9243.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.