Heartbeat issue : Bad Gateway: couldn't connect to any of the configured Elasticsearch hosts

Hello Experts,

I am having issue to connect Heartbeat to Elasticsearch instance (Cloud).


I have a Linux server, Heartbeat Version 7.5.0 is running on it and sending Data to Elasticsearch instance (Cloud).
But that Data is not picked up by Alerts (Rules) and clients don't get any alert email.

Elastic Cloud Instance is of latest version.

so to resolve this issue, I stopped Heartbeat Service for Version 7.5.0 and installed Heartbeat Version 7.16.3 on Linux server but it shows below error,

Expecting solutions from you experts :slightly_smiling_face:

Hi @aji.shinde7,

There're serveral ways of connecting to an Elastic Cloud instance, can you please let us know whether you're setting the host directly in output.elasticsearch.hosts or using a combination of cloud.id/cloud.auth?

There shouldn't be an incompatibility so I'd recommend testing using cloud.id and cloud.auth as they are the preferred way to connect to cloud.

cloud.id: "<deployment id>"
cloud.auth: "<cloud auth>"

Hi emilioalvap,

I am using cloud.id and cloud.auth. Tried with 'output.elasticsearch.hosts ' as well. I am confused on using double quotes (") and certificate with extension ".pem"

I there something to do with SSL/TLS ?

Hi @aji.shinde7,

Config seems correct, it doesn't seem like the error would be related to heartbeat specifically.

Since this is happening on Elastic Cloud, could you open a support request for cloud team? They will be able to ascertain that all infrastructure elements are working correctly and. if needed be, reach out to us with more information.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.