Connection refused 9200


I am new to ELK,I just tried to setup ELK v7 in centos 7 64bit os. While running curl getting connection refused in elasticsearch.In below i sahred my conf file and log details.

Note:selinux is disabled and firewall is masked

======================== Elasticsearch Configuration =========================

NOTE: Elasticsearch comes with reasonable defaults for most settings.

Before you set out to tweak and tune the configuration, make sure you

understand what are you trying to accomplish and the consequences.

The primary way of configuring a node is via this file. This template lists

the most important settings you may want to configure for a production cluster.

Please consult the documentation for further information on configuration options:

---------------------------------- Cluster -----------------------------------

Use a descriptive name for your cluster: my-application

------------------------------------ Node ------------------------------------

Use a descriptive name for the node: node-1

Add custom attributes to the node:

#node.attr.rack: r1

----------------------------------- Paths ------------------------------------

Path to directory where to store the data (separate multiple locations by comma): /var/lib/elasticsearch

Path to log files:

path.logs: /var/log/elasticsearch

----------------------------------- Memory -----------------------------------

Lock the memory on startup:

#bootstrap.memory_lock: true

Make sure that the heap size is set to about half the memory available

on the system and that the owner of the process is allowed to use this


Elasticsearch performs poorly when the system is swapping the memory.

---------------------------------- Network -----------------------------------

Set the bind address to a specific IP (IPv4 or IPv6):

Set a custom port for HTTP:

http.port: 9200

For more information, consult the network module documentation.

--------------------------------- Discovery ----------------------------------

Pass an initial list of hosts to perform discovery when this node is started:

The default list of hosts is ["", "[::1]"]

#discovery.seed_hosts: ["host1", "host2"]

Bootstrap the cluster using an initial set of master-eligible nodes:

#cluster.initial_master_nodes: ["node-1", "node-2"]

For more information, consult the discovery and cluster formation module documentation.

---------------------------------- Gateway -----------------------------------

Block initial recovery after a full cluster restart until N nodes are started:

#gateway.recover_after_nodes: 3

For more information, consult the gateway module documentation.

---------------------------------- Various -----------------------------------

Require explicit names when deleting indices:

#action.destructive_requires_name: true

Elastic search log:

[2019-06-02T08:49:14,425][INFO ][o.e.t.TransportService ] [] publish_address {}, bound_addresses {}
[2019-06-02T08:49:14,431][INFO ][o.e.b.BootstrapChecks ] [] bound or publishing to a non-loopback address, enforcing bootstrap checks
[2019-06-02T08:49:14,434][ERROR][o.e.b.Bootstrap ] [] node validation exception
[1] bootstrap checks failed
[1]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured
[2019-06-02T08:49:14,439][INFO ][o.e.n.Node ] [] stopping ...
[2019-06-02T08:49:14,455][INFO ][o.e.n.Node ] [] stopped
[2019-06-02T08:49:14,456][INFO ][o.e.n.Node ] [] closing ...
[2019-06-02T08:49:14,467][INFO ][o.e.n.Node ] [] closed
[2019-06-02T08:49:14,470][INFO ][o.e.x.m.p.NativeController] [] Native controller process has stopped - no new native processes can be started

Please format your code, logs or configuration files using </> icon as explained in this guide and not the citation button. It will make your post more readable.

Or use markdown style like:


This is the icon to use if you are not using markdown format:

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.
Please update your post.

About your problem please read

sure thanks for the inputs.Let me correct my mistakes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.