Could not find a version that satisfies the requirement MarkupSafe>=0.23 (from Jinja2==2.9.5->esrally==1.0.4) (from versions: ) No matching distribution found for MarkupSafe>=0.23 (from Jinja2==2.9.5->esrally==1.0.4)


(swapnali) #1

Hello,

I am Trying to install rally (Offline) i have installed python version 3.6 and pip 9.10

i am getting the below error kindly help me for this

" Could not find a version that satisfies the requirement MarkupSafe>=0.23 (from Jinja2==2.9.5->esrally==1.0.4) (from versions: )
No matching distribution found for MarkupSafe>=0.23 (from Jinja2==2.9.5->esrally==1.0.4) "


(Daniel Mitterdorfer) #2

Hi,

I just inspected Rally's offline install package and noticed that MarkupSafe is platform-dependent and Rally only ships with the MacOS package but I assume you run on Linux. We need to look into whether we can include all variations of a platform-dependent binary in the offline installation package. As a workaround you can download the MarkupSafe binary for your platform yourself from https://pypi.org/project/MarkupSafe/1.1.0/#files and place it in the bin subdirectory of the extracted Rally offline installation package (untested but pip should then be able to pickup the correct package).

Daniel


(Daniel Mitterdorfer) #3

Hi,

alternatively you can also download the platform-indepenent source package (it's the last one, or the only tar.gz, in the list on PyPI). I've also raised https://github.com/elastic/rally/pull/682 which will fix this in Rally 1.1.0. Thanks for bringing this up.

Daniel


(swapnali) #4

Thank you so much for your reply


(andy_zhou) #5

need use pip3 setup.py install with MarkupSafe
i down the MarkupSafe and install the error is slove.