Couldn't Make the Package of metricbeats in Windows-7 32 bit

#1

Hi-
I have to Make Package of metricbeats (got to test couple of bugs in Windows module which has been fixed, which is still in a pull request, but not yet into the master), but its failing with an error message as below:

Could someone please help me to fix this error:

C:\Users\Administrator\go\src\github.com\elastic\beats\metricbeat>make package
C:\Users\Administrator\go\bin\mage.exe
package ran for 0s
Error: failed to find github.com/elastic/beats/dev-tools/mage in the project's v
endor
C:\Users\Administrator\go\src\github.com\elastic\beats\metricbeat>make
Targets:
  build                 builds the Beat binary.
  buildGoDaemon         builds the go-daemon binary (use crossBuildGoDaemon).
  clean                 cleans all generated files and build artifacts.
  crossBuild            cross-builds the beat for all target platforms.
  crossBuildGoDaemon    cross-builds the go-daemon binary using Docker.
  crossBuildXPack       cross-builds the beat with XPack for all target platform
s.
  exportDashboard       exports a dashboard and writes it into the correct direc
tory Required ENV variables: * MODULE: Name of the module * ID: Dashboard id
  fields                generates a fields.yml for the Beat.
  goTestIntegration     executes the Go integration tests.
  goTestUnit            executes the Go unit tests.
  golangCrossBuild      build the Beat binary inside of the golang-builder.
  package               packages the Beat for distribution.
  testPackages          tests the generated packages (i.e.
  update                updates the generated files (aka make update).

go version - go version go1.12.1 windows/386

(ruflin) #2

Seems like you are missing mage: https://github.com/magefile/mage

#3

@ruflin -
I installed the mage, and found a new binary added in the Go bin path, but still I see the same error: :frowning:

C:\Users\Admin\Go\src\github.com\elastic\beats\metricbeat>make package
C:\Users\Admin\Go\bin\mage.exe
package ran for 1ms
Error: failed to find github.com/elastic/beats/dev-tools/mage in the project's v
endor
(ruflin) #4

I have to confess that most of us develop on OS X and Linux and because of this sometimes the dev tools are not working properly on Windows. But the above more looks like a missing directory which should not be related to the OS. What version did you check out of Github? Are you on master?

#5

Hi @ruflin-
I have cloned @maddin2016 repo (https://github.com/martinscholz83/beats)

Its related to the issues 9847 and 10060
Since, the issue is with the Windows-7 32 bit, trying to build the package with the same OS configuration.

(ruflin) #6

I see, perhaps it makes sense to rebase on master as lots of things have changed since January.

#7

@ruflin
That worked; could able to built the package now. Thanks so much !

Any timelines, when this PR could move to the Master (https://github.com/elastic/beats/pull/9847) ?.
So, I can just take the snapshot builds from the Jenkins CI. Thanks !

(ruflin) #8

The PR you linked is from the community. Best ping Martin on it on how it looks from his side priority wise.

(system) closed #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.