Courier fetch: response is null

Whenever I try to use a visualization, dashboard or the discovery tab I get the following error:

Courier fetch: response is null

Version: 7.5.1
Build: 27610
Error: response is null

No one else in my team is getting it. I've tried googling it but I can't find any information about it. Here's the console output:

INFO: 2020-06-03T13:25:51Z
  Adding connection to

TypeError: "response is null"

The only difference I have from others in my team is that I'm using ubuntu linux and the internet connection I guess.

Our elk stack is running on "elasticsearch on kubernetes".

What browser are you using?

Also, could you open the Developer Tools and go to the Network tab? The request causing the problem should show up there. Copying the request and response (if there is one) could be helpful.

If you are using the security solution it might also be helpful to check the roles associated with your user (whether there are any differences to your team mates)

Firefox version:

$ firefox --version
Mozilla Firefox 76.0.1

The only request that isn't a 200 or 304 is this one (it doesn't have a http status code):

These are some of the headers:

POST /elasticsearch/adspy2*/_search?rest_total_hits_as_int=true&ignore_unavailable=true&ignore_throttled=true&preference=1591192933292&timeout=30000ms HTTP/1.1
User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:76.0) Gecko/20100101 Firefox/76.0
Accept: application/json, text/plain, */*
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
content-type: application/json
kbn-version: 7.5.1
Content-Length: 489
Connection: keep-alive

And there's no response.

Regarding to security, we are all using the same user.

Also.I tried chrome and it seems it's working ok there.

This request looks like like a Courier request. It's interesting this is only happening in firefox - could you check whether the same request is there in Chrome as well and whether there are any differences in parameters/payload?

The only difference in the url is "preference":
...&preference=1591192933292&... vs ...&preference=1591200605660&...

in the headers the only difference I see is the User-agent:

POST /elasticsearch/adspy2*/_search?rest_total_hits_as_int=true&ignore_unavailable=true&ignore_throttled=true&preference=1591200353102&timeout=30000ms HTTP/1.1
Connection: keep-alive
Content-Length: 823
Accept: application/json, text/plain, */*
kbn-version: 7.5.1
User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.149 Safari/537.36
content-type: application/json
Accept-Encoding: gzip, deflate
Accept-Language: en-US,en;q=0.9

Maybe I should try another firefox version?

I can’t reproduce the problem with Firefox. Do you have the ability to check whether this is happening with the latest version 7.7.1 as well?

Sure I'll try.

I'm seeing this aswell. Firefox 77.0.1, Elasticsearch 7.6.1.
Interestingly the same url gives me a response is null


in Firefox, but in Chrome the error message is
Cannot read property 'timed_out' of null


The triggering url looks like

Update: the index pattern that I was working on had both the words "ad" and "google" in there, and that had the adblocker kick in, which just so happened to be installed on both browsers :smiley:
Deactivating the adblocker solved the issue.

That's an interesting one, thanks for updating the thread :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.