CPU/Memory consumption after upgrading to Version 5.1.2


(Tobias Kraft) #1

Hi,

last week I upgraded metricbeat from version 5.1.1 to version 5.1.2.

When I take a look at the memory and also the CPU consumption of metricbeat itself for the last 7 days it seems that metricbeat is continuously consuming more memory and CPU. After restarting the metricbeat process it seems working fine again, but memory and CPU load starts increasing again (see also attached screenshot).

Are there any known issues or hints?

We are running metricbeat on Ubuntu Linux 16.04 and have activated the standard metrics and also monitoring for docker containers.

Many thanks,
Tobias


(ruflin) #2

Reminds me of https://github.com/Ingensi/dockbeat/issues/139 Is there any chance that you could check if the memory issue also happens without the docker module?


(Tobias Kraft) #3

Hi Nicolas,

I have now disabled docker and will provide feedback in a few days on the memory and the CPU usage.


(ruflin) #4

Thanks for testing this. Let me know as soon as you have some indications here.

How many containers are you monitoring? In case it is docker, my first assumption is that we leak some http handlers or something similar.


(Tobias Kraft) #5

Hi Nicolas,

we are monitoring currently only 6 Containers. The monitoring period was set to 20s.


(Tobias Kraft) #6

Hi Nicolas,

we are now monitoring our server for three days without the docker metrics and it seems that metricbeat is running fine. Memory and CPU is not increasing.

As a workaround I will now activate the docker metrics again and restart metricbeat every hour by adding a crontab entry.


(ruflin) #7

Ok, that sounds like there is some memory leak in the docker module. Could you open a Github issue for that? https://github.com/elastic/beats


(Tobias Kraft) #8

Here is the Github issue: https://github.com/elastic/beats/issues/3489


(ruflin) #9

Thanks. Lets continue the conversation there.


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.