Create a repository failed


#1

i am trying to create repository:

PUT _snapshot/backup
{
  "type" : "azure"
}

but get the following error:

{
  "error": {
    "root_cause": [
      {
        "type": "settings_exception",
        "reason": "Failed to get setting group for [] setting prefix and setting [account] because of a missing '.'"
      }
    ],
    "type": "repository_exception",
    "reason": "[backup] failed to create repository",
    "caused_by": {
      "type": "settings_exception",
      "reason": "Failed to get setting group for [] setting prefix and setting [account] because of a missing '.'"
    }
  },
  "status": 500
}

FYI,in elasticsearch.yml config file, i put

cloud:
   azure:
        storage:
                account:  XXXXXXX
                key: XXXX

do i miss some setting in elasticsearch?

thanks a lot!


(David Pilato) #2

Please format your code using </> icon as explained in this guide. It will make your post more readable.

Or use markdown style like:

```
CODE
```

I updated your question.

I guess you are using a recent version, right?

It should be:

cloud:
   azure:
        storage:
            my_account:
                account:  XXXXXXX
                key: XXXX


(Casie Owen) #3

Thanks dadoonet, we discovered the "my_account:" change last night and that did indeed resolve the issue. The last version we created repositories on was 1.7.2, and "my_account:" was not part of the syntax in that version.


#4

Thanks for updating my question, dadoonet. i will make sure that my future post be more readable.

Before, i thought only when you define more than one account, you need put "my_account:" there. Nice to learn. thanks dadoonet!(https://www.elastic.co/guide/en/elasticsearch/plugins/5.4/repository-azure-usage.html)

it works well. thanks both of your help, dadoonet and Casie!


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.