Creating a new custom index for haproxy metricbeat


I cannot seem to get a new custom index created in elastic when trying output from metricbeat using the haproxy module. I have a 3 node cluster in operation. I can see the kibana dashboards install into kibana and the index pattern appears in the visualizations but i cannot see the index itself being created.

Metricbeat Config:
#==================== Elasticsearch template setting ==========================
index.number_of_shards: 1
index.codec: best_compression
output.elasticsearch.index: "haproxyES-%{[agent.version]}-%{+yyyy.MM.dd}" "haproxyES"
setup.template.pattern: "haproxyES-"
setup.dashboards.index: "haproxyES-



Have you re-run metricbeat --setup ? Can you confirm that data is being ingested into elasticsearch at all with these settings?

I`ll re-run it and confirm :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.