Creating index with _timestamps


(Surajit Roy) #1

Hi All,

I am trying to create an index with a _timestamp mapping.

curl -XPOST "http://localhost:9200/test" -d'
{ "settings" :
{ "number_of_shards" : 5,
"number_of_replicas" : 1},
"mappings" : {
"stats" : {
"_timestamp" : {
"enabled" : true,
"store" : true }
}}}'

When I am writing the data in the index I dont see the time stamp coming up

curl -XPOST "http://localhost:9200/test/stats/1" -d'{"a":1}'

{"_index":"test","_type":"stats","_id":"1","_version":1,"created":true}

Why am I not getting _timestamp, can anyone help?

Thanks
Surajit

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAAxzCObuchG-a-tBfDQa-u3_ahX7hoaPq8g3jgVZXMBiEJH4oA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

Ask for it using fields: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-request-fields.html#search-request-fields

Using timestamp does not modify the original source.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 21 juil. 2014 à 12:44, Surajit Roy beasurajitroy@gmail.com a écrit :

Hi All,

I am trying to create an index with a _timestamp mapping.

curl -XPOST "http://localhost:9200/test" -d'
{ "settings" :
{ "number_of_shards" : 5,
"number_of_replicas" : 1},
"mappings" : {
"stats" : {
"_timestamp" : {
"enabled" : true,
"store" : true }
}}}'

When I am writing the data in the index I dont see the time stamp coming up

curl -XPOST "http://localhost:9200/test/stats/1" -d'{"a":1}'

{"_index":"test","_type":"stats","_id":"1","_version":1,"created":true}

Why am I not getting _timestamp, can anyone help?

Thanks
Surajit

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAAxzCObuchG-a-tBfDQa-u3_ahX7hoaPq8g3jgVZXMBiEJH4oA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/873351B2-4C21-406A-B606-D9E8EE4A410D%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(system) #3