Creating Snapshot repository, Linux and windows paths get mixed. Why?

I have 3 Nodes. 2 on Windows and 1 on linux. I want to try the snapshoting feature. As far as I know I have to set the path.repoon every node. So I created the network drive e which is on the PC Scot

  1. Windows1 path.repo: ["\\\\SCOT\\e\\SnapshotTesting"]
  2. Windows2 path.repo: ["\\\\SCOT\\e\\SnapshotTesting"]
  3. Linux:
    I mounted SCOT with: sudo mount.cifs //IPofScot/e/SnapshotTesting /mnt/share -o user=user
    With this I can access the SnapshotTesting with /mnt/share.
    So I set path.repo: /mnt/share

Now I tried the following API (on Windows1):

  "type": "fs",
  "settings": {
    "location": "\\\\SCOTTY\\e\\SnapshotTesting"

But I get the following error:

'RemoteTransportException[[batman_node3][][internal:admin/repository/verify]]; nested: RepositoryException[[my_backup2] cannot create blob store]; nested: FileSystemException[**/mnt/share/\\\\SCOT\\e\\SnapshotTesting**: The argument is invalid];']]"

Why does it mix up the 2 paths? How can I fix this?


The path must be the same across all nodes, which makes it hard to use file system snapshots on mixed OS cluster (which is not recommended anyway).

1 Like

Ok good to know. Is there any way to backup this system? Maybe stop allocation, put node 3 away and thank backup node 1 and 2? Its all experimental, so I just try to understand what is possible. If its not possible at all its fine too^^


Maybe, but have never tried it.

Is it ok if I just manually backup the indices folders? They should store all the data right?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.