Curator ignores everything


#1

I'm running curator from the command line passing an action and a config file. I'm managed to make it run apparently properly once:
curator --config curator-config.yml curator-action.yml
2018-02-07 17:55:22,823 INFO Preparing Action ID: 1, "delete_indices"
2018-02-07 17:55:22,829 INFO GET http://kibana:9302/ [status:200 request:0.004s]
2018-02-07 17:55:22,830 INFO Trying Action ID: 1, "delete_indices": Delete indices older than 30 days (based on index name), for logstash- prefixed indices. Ignore the error if the filter does not result in an actionable list of indices (ignore_empty_list) and exit cleanly. , logstash-smis-vexpsessioninfoext, logstash-smis-vtrainings-completed
2018-02-07 17:55:22,833 INFO GET http://kibana:9302/_all/_settings?expand_wildcards=open%2Cclosed [status:200 request:0.003s]
2018-02-07 17:55:22,834 INFO GET http://kibana:9302/ [status:200 request:0.000s]
2018-02-07 17:55:22,845 INFO GET http://kibana:9302/_cluster/state/metadata/.kibana,.monitoring-alerts-6,.monitoring-es-6-2018.01.30,.monitoring-kibana-6-2018.01.30,.security-6,.triggered_watches,.watcher-history-7-2018.01.30,.watches,172.16.0.1,172.16.1.2,172.16.1.25,172.16.1.26,172.16.1.27,172.16.1.28,filebeat-6.1.3-2018.02.06,logstash-smis-vdashb-proposals,logstash-smis-vdashb-scheduled-exp [status:200 request:0.011s]
2018-02-07 17:55:22,879 INFO GET http://kibana:9302/.kibana,.monitoring-alerts-6,.monitoring-es-6-2018.01.30,.monitoring-kibana-6-2018.01.30,.security-6,.triggered_watches,.watcher-history-7-2018.01.30,.watches,172.16.0.1,172.16.1.2,172.16.1.25,172.16.1.26,172.16.1.27,172.16.1.28,filebeat-6.1.3-2018.02.06,logstash-smis-vdashb-proposals,logstash-smis-vdashb-scheduled-exp/_stats/store,docs [status:200 request:0.032s]
2018-02-07 17:55:22,882 INFO Skipping action "delete_indices" due to empty list: <class 'curator.exceptions.NoIndices'>
2018-02-07 17:55:22,882 INFO Action ID: 1, "delete_indices" completed.
2018-02-07 17:55:22,882 INFO Job completed.

However now, every time I run it I just receive nothing, even no errors by setting, i.e., a wrong server name....

Any idea? Is there any generated log?

Thanks,
Marco


(O. Ododa) #2

You can change curator's logging level in your configuration file by including this:

logging:
  loglevel: DEBUG
  logfile:
  logformat: default
  blacklist: ['elasticsearch', 'urllib3']

Changing loglevel to 'DEBUG' will show you more information.


#3

Thanks!


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.