Curator optimize operation timeout gets override by default value of 21600


(Sravan Kumar) #1

In elasticsearch cluster, while performing the curator optimize operation for logstash & marvel indices.
This works.
However, the timeout configured for the curator optimize is not considered.
Configured value 5000 for timeout is overriden by default timeout of 21600.
Please check.
Currently, we are using curator version of 3.4.0.
Thanks.


(Aaron Mildenstein) #2

I've also responded to this question in the issue you created in the GitHub repository.

Curator 3.4 only overrides the default value of 30 seconds if no default value is provided

The code that overrides that value is here.

The --request-timeout flag value is different, and doesn't work correctly or have an effect beyond the regular client --timeout value, which is why this setting is omitted in future versions of Curator.

You should know that Curator 3.5.1 is the last one in the Curator 3.x series, and was release 2016-03-21—nearly 2 years ago. The version you're using, 3.4.0, was released 2015-10-28, well over 2 years ago. Neither version is supported any longer, as the versions of Elasticsearch they support are no longer supported either. If you are compelled to use an older version of Curator, you should at least use version 3.5.1, with the latest settings. If you're stuck with 3.4.0, you probably got it from an alternate repository, as that's the latest version I've seen bundled in some of those repositories. You can use the official repositories for 3.5 to download a newer version of the 3.x series. By way of comparison, Curator 4 supports Elasticsearch 2.x and 5.x installs. Curator 5 supports Elasticsearch 5.x and 6.x installs.

The version you're requesting a change for is very much no longer supported. I suggest you upgrade to a newer version of both Curator and Elasticsearch. The forcemerge (which used to be called optimize in the 1.x and older versions of Elasticsearch) API call takes a long time to execute, which is why the timeout is increased to a very large number if unset. Curator waits for this call to complete before returning so that you do not attempt to execute another action until the forcemerge (optimize) is complete. This Elasticsearch behavior has not changed in any version since the beginning, though the API call has been renamed.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.