Curator SSL problem/question

Hi all,

I'm using elastic-curator in a cron job to run automated tasks. My company's cron server is being migrated from CentOS 6 (python-elasticsearch-curator v 2.0.1) to CentOS 7 (elastic-curator v3.2.3)

I tried to update the commands to reflect new flags in v3.2.3, but having an issue with SSL. The following command works fine on the old CentOS 6 box:

/usr/bin/curator --host --port 8444 --ssl --auth 'user:password' close --prefix logstash- --older-than 10

I updated the flags and ran the following command on the new CentOS 7 box:

/usr/bin/curator --host --port 8444 --use_ssl --http_auth user:password' show indices --prefix "logstash-" --older-than 3 --time-unit days --timestring '%Y.%m.%d'

but get the following error:

2016-04-18 16:06:58,234 INFO Job starting: show indices
2016-04-18 16:06:58,234 INFO Attempting to verify SSL certificate.
2016-04-18 16:06:58,235 WARNING Unable to verify SSL certificate.
ERROR: Connection failure.

After using the --debug flag and doing a bit of research, I think this is happening because our site uses a self-signed cert. I tried to use --ssl-no-validate, but it doesn't recognize that flag, so it must only be available in v3.3+

Any suggestions?

Curator 3.3 introduced the --ssl-no-validate flag. Your only choice is to either upgrade curator or don't use a self signed cert.