Curl_rc 7 error when using nfs trident

hello, i installed Elasticsearch 7.15.0 on openshift 4.6, our openshift is running on vmware vms.
we have 2 storage classes:

  1. the vmware datastore that provides storage for pods with iscsi.
  2. the trident that connects to netapp and provides nfs.

when trying to create Elasticsearch cluster using the vmware iscsi as the storage class, everything works great, the pods are running 1/1 and everything is cool. when doing describe on the pods there is curl_rc 7 error only like 4-5 times, but then everything is running successfully.

but when deploying the Elasticsearch on trident nfs, the pods are stuck at running 0/1, and when doing describe on them or when checking the logs the only error message that is repeating like 2000 times is:
Readiness probe failed: {"timestamp": "2021-10-27T10:42:12+00:00", "message": "readiness probe failed", "curl_rc": "7"}

we also tried to install Elasticsearch 7.10.0, we had the same problem.

we also tried to install es 7.15.0 on minikube (we didnt configured there any storage class so i guees its using the default whatever is configured), and we also had the same problem of curl_rc 7 fails. (i guess the Elasticsearch just doesnt wants to start)

we are trying to move to trident, because vmware datastore causes us problems when electricity gets cut off and then gets back on again.
so it would be nice if anyone could please help us to solve the problem and make it work for trident nfs

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.