Custom analysis, phonetic filter and highlighting


(Erdal Gunyar) #1

Hi everybody ! :slight_smile:

I've got an issue when I try to apply a phonetic filter : I do not have any
highlight anymore.

Here is the settings used :
"analysis": {
"analyzer": {
"my_analyzer": {
"filter": [
"standard",
"lowercase",
"my_stemmer",
"my_phonetic"
],
"tokenizer": "standard"
}
},
"filter": {
"my_stemmer": {
"type": "stemmer",
"replace": "false",
"name": "french"
},
"my_phonetic": {
"replace": "false",
"type": "phonetic",
"languageset": [
"french",
"english",
"german"
],
"encoder": "beidermorse"
}
}
}

Without this filter, more precisely if I use those filters, then it works :
"my_analyzer": {
"filter": [
"lowercase",
"asciifolding",
"my_stemmer"
],
"tokenizer": "standard"
}

Does anyone can help me ? Or have a piece of idea by any chance ?

Thanks,

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2a146c45-bfdb-40e6-9f44-2ab369d1d916%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Erdal Gunyar) #2

Well, since I've posted this message I didn't find any reliable solution,
it looks like a bug in the phonetic plugin.

There is at least a workaround : as I'm using my custom analysis in _all,
the workaround consists to put a more standard analyser on the wanted field
(for ex. "content") and to use the "highlight_query" on it. But it will
only highlight when the standard analyser returns the same query (i.e. when
if you query "quik" instead of "quick", highlighter won't work).

Have a good day all !

Erdal.

Le lundi 24 mars 2014 18:03:57 UTC+1, Erdal Gunyar a écrit :

Hi everybody ! :slight_smile:

I've got an issue when I try to apply a phonetic filter : I do not have
any highlight anymore.

Here is the settings used :
"analysis": {
"analyzer": {
"my_analyzer": {
"filter": [
"standard",
"lowercase",
"my_stemmer",
"my_phonetic"
],
"tokenizer": "standard"
}
},
"filter": {
"my_stemmer": {
"type": "stemmer",
"replace": "false",
"name": "french"
},
"my_phonetic": {
"replace": "false",
"type": "phonetic",
"languageset": [
"french",
"english",
"german"
],
"encoder": "beidermorse"
}
}
}

Without this filter, more precisely if I use those filters, then it works :
"my_analyzer": {
"filter": [
"lowercase",
"asciifolding",
"my_stemmer"
],
"tokenizer": "standard"
}

Does anyone can help me ? Or have a piece of idea by any chance ?

Thanks,

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f4c79190-da38-4ccf-847a-33f46e286aae%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3