Custom Analyzer Validation

We are trying to cover the corner cases in our project and in one of the
invalid custom analyzer scenarios not captured in validation. The invalid
custom analyzer is not captured on settings update. Is it a known issue?

PUT http://localhost:9200/test_idx
Content-Type: application/json
{
"settings" : {
"number_of_shards" : 3,
"number_of_replicas" : 2
}
}
-- response --
200 OK
Content-Type: application/json; charset=UTF-8
Content-Length: 21

{"acknowledged":true}

=============================

POST http://localhost:9200/test_idx/_close
Content-Type: application/json

-- response --
200 OK
Content-Type: application/json; charset=UTF-8
Content-Length: 21

{"acknowledged":true}

================================

PUT http://localhost:9200/test_idx/_settings
Content-Type: application/json
{
"analysis": {
"analyzer": {
"my_custom_analyzer_1": {
"tokenizer": "my_custom_tokenizer"
}
}
}
}
-- response --
200 OK
Content-Type: application/json; charset=UTF-8
Content-Length: 21

{"acknowledged":true}

===============================

POST http://localhost:9200/test_idx/_open
Content-Type: application/json

-- response --
200 OK
Content-Type: application/json; charset=UTF-8
Content-Length: 21

{"acknowledged":true}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3eafcb49-c0aa-4bbf-9d90-4559ca831dcb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks for raising this. It looks like this is indeed a bug. I have raised
an issue for it on
github: https://github.com/elasticsearch/elasticsearch/issues/9879

Colin

On Wednesday, 25 February 2015 14:03:28 UTC, Balasundaram Nanthisamy wrote:

We are trying to cover the corner cases in our project and in one of the
invalid custom analyzer scenarios not captured in validation. The invalid
custom analyzer is not captured on settings update. Is it a known issue?

PUT http://localhost:9200/test_idx
Content-Type: application/json
{
"settings" : {
"number_of_shards" : 3,
"number_of_replicas" : 2
}
}
-- response --
200 OK
Content-Type: application/json; charset=UTF-8
Content-Length: 21

{"acknowledged":true}

=============================

POST http://localhost:9200/test_idx/_close
Content-Type: application/json

-- response --
200 OK
Content-Type: application/json; charset=UTF-8
Content-Length: 21

{"acknowledged":true}

================================

PUT http://localhost:9200/test_idx/_settings
Content-Type: application/json
{
"analysis": {
"analyzer": {
"my_custom_analyzer_1": {
"tokenizer": "my_custom_tokenizer"
}
}
}
}
-- response --
200 OK
Content-Type: application/json; charset=UTF-8
Content-Length: 21

{"acknowledged":true}

===============================

POST http://localhost:9200/test_idx/_open
Content-Type: application/json

-- response --
200 OK
Content-Type: application/json; charset=UTF-8
Content-Length: 21

{"acknowledged":true}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f4912afb-a583-46dd-8a96-e69e169a71b5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.