Custom_filters_score "No filter registered for [match]"


(paul) #1

When i use "term" the query works but when i change it to "match" it does
not work but rather throws a exception. "No filter registered for [match]"
{
"query": {
"custom_filters_score": {
"query": {
"match_all": {}
},
"filters": [
{
"filter": {
"range": {
"tution": {
"from": 10000,
"to": 20000
}
}
},
"boost": "3"
},
{
"filter": {
"term": {
"programs": "computer"
}
},
"boost": "2"
},
{
"filter": {
"term": {
"coed": "Yes"
}
},
"boost": "1"
}
],
"score_mode": "first"
}
}
}

--
Paul

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Yes there is no Match filter but Match query.

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/query-dsl-filters.html
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/query-dsl-queries.html

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 22 nov. 2013 à 06:34, paul avinashpaul85@gmail.com a écrit :

When i use "term" the query works but when i change it to "match" it does not work but rather throws a exception. "No filter registered for [match]"
{
"query": {
"custom_filters_score": {
"query": {
"match_all": {}
},
"filters": [
{
"filter": {
"range": {
"tution": {
"from": 10000,
"to": 20000
}
}
},
"boost": "3"
},
{
"filter": {
"term": {
"programs": "computer"
}
},
"boost": "2"
},
{
"filter": {
"term": {
"coed": "Yes"
}
},
"boost": "1"
}
],
"score_mode": "first"
}
}
}

--
Paul

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3