Custom index using ES 7.1.0

Hi,
I am trying to generate custom index into elastic search from filebeat with the following config: (using both 7.1.0 versions) , but unable to see this index - oraclesidecar-%{[agent.version]}-%{+yyyy.MM.dd} on the elastic search / kibana management index page. Any ideas why / what is wrong in the below config?

The reason for this behaviour you have discovered lies in this documentation page:
https://www.elastic.co/guide/en/beats/filebeat/7.1/elasticsearch-output.html#_index
https://www.elastic.co/guide/en/beats/filebeat/7.1/ilm.html
The default behaviour has changed since 7.0 for setup.ilm.enabled.
So you have two options. one would be to set false for this value.
2nd possibility: you just leave out index value and reconfigure the values setup.ilm.rollover_alias and setup.ilm.pattern.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.