Logs geeting stored in default filebeat 7.7.1 index and custom index not getting created

Hi all,

I am trying to send my log data from filebeat to Elasticsearch directly in .log format.It is not going to the custom index I created and getting stored under the default indice filebeat 7.7.1 . Also I could not see the custom index in the list of available indices.

Host: “localhost:9200”
Index: “custom-%{+yyyy.MM.DD}”
Setup.template.name: “custom”
Setup.template.pattern: “custom-*”

Hi @Avinash_sanapala,

Since 7.0, Beats indexes are managed by ILM, and they have a different set of settings to customize index names. Take a look to these docs: https://www.elastic.co/guide/en/beats/filebeat/7.7/ilm.html

In any case, why do you want to customize index names? It is usually not needed and to have it working correctly several settings have to be taken into account.

You may also consider disabling ILM, but it uses to be a good thing to use it.

Thanks Jaime Soriano !
the reason why I was looking for different custom index other than default filebeat 7.7.1 is to create a kind of namespace to different logs of my application for different regions. I will better go through the doc you have sent.Thanks for your time.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.