Custom token filter for Wordnet Hypernyms

(Avanish Raju) #1

I'm writing a custom token filter for using WordNet hypernyms instead of synonyms.

When I install the plugin and restart the server, I get the error that "hypernym requires hypernyms_path to be configured" which is obviously coming from my token filter factory.

However, I've not yet defined any index to use the filter - I've merely installed it. How do I make sure the custom token filter is only loaded when I configure "hypernym" as a token filter in an index setting? (Like, for example "synonyms" does)

I'd really appreciate a nudge in the right direction as this is my first ES plugin and my first custom filter.

(Avanish Raju) #2

I figured ths one out. I was missing an annotation on my TokenFilterFactory;


And now there's no error.

(system) #3