Dashboards not showing in custom kibana space

I have created a two space in kibana one for production which is default space and second is for staging. on my production space all indexes are showing into it but on my staging space there is only staging index is showing as i have only attached that index to staging space. Now i have installed filebeat on remote server to send the data to staging space but the issue is when i loading the dashboards on it from my remote server the dashboards are not loading onto my staging space. However i can see the logs of remove server in Discovery tab which means filebeat is sending data but the dashboards are not loading.
Index names are same on filebeat as its set on kibana.

I am using the below commands to load the index and dashboards on kibana;-

  • filebeat setup --index-management -E output.logstash.enabled=false -E output.elasticsearch.username="elastic" -E output.elasticsearch.password="LOusdfsadfgNnUzgahp" -E 'output.elasticsearch.hosts=["http://52.xxx.xxx.xxx:9200"]'

  • filebeat setup -e -E output.logstash.enabled=false -E output.elasticsearch.username="elastic" -E output.elasticsearch.password="LOUgahzdsfdp" -E output.elasticsearch.hosts=["http://52.xxx.xxx.xxx:9200"] -E output.elasticsearch.username=elastic -E output.elasticsearch.password=LOupmFVKkXXNnUzgahp -E setup.kibana.host=http://52.xxx.xxx.xxx:5601

Hi @huzaifa224

What version are on?

I'm not sure. I'm completely following but dashboards only load into the default space. Then you need to copy them from the default space over to your new staging space from within Kibana - Stack Management - Saved objects That's how it works.

Perhaps I'm not understanding the question

Thanks @stephenb
You understand the correctly, if i copy the dashboards from default space to the custom space then i have to change the source index in all dashboard of custom space as in it the index name is staging-* and in default space the index name is file
Is there any way i can change the source index of custom space's dashboard in one go instead to change them 1 by 1?

I am using V7.17

Hi @huzaifa224

No .. Not as far as I know... but I think there is a fairly simple answer / approach

Perhaps name your indices like




Then the index pattern

beat-* will work in both spaces / dashboards and only allow the appropriate indices in each space, that is what most people do in this case

Hi @stephenb
Thanks for your help, i still didn't found the solution of it. I have manually created the dashboard on the custom space for other index.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.