Data and non-data nodes


(Szymon Gwóźdź) #1

Hi!

I've launched 4 instances of ElasticSearch (on one cluster - LocalCluster).
2 instances (test-1 and test-2) have configuration:

http:
enabled: true

data:
enabled: false

And 2 other instances (test-3 and test-4) have configuration:

http:
enabled: false

data:
enabled: true

But when I'm putting data to test-1 (using curl) I see that size of work
directory work/LocalCluster is growing on test-1 and test-4, but in not
growing on test-2 and test-3. Why is that? test-3 and test-4 are data nodes,
test-1 and test-2 are non-data noded, but data seems to be stored in some
other way. What is the explanation of that?

Regards
Szymon Gwóźdź


(Shay Banon) #2

The configuration to enable or disable a data node is:

node:
data: false

(the above disables a node from holding data).

Try that and see if it works...

cheers,
shay.banon

2010/4/15 Szymon Gwóźdź sz.gwozdz@gmail.com

Hi!

I've launched 4 instances of ElasticSearch (on one cluster - LocalCluster).
2 instances (test-1 and test-2) have configuration:

http:
enabled: true

data:
enabled: false

And 2 other instances (test-3 and test-4) have configuration:

http:
enabled: false

data:
enabled: true

But when I'm putting data to test-1 (using curl) I see that size of work
directory work/LocalCluster is growing on test-1 and test-4, but in not
growing on test-2 and test-3. Why is that? test-3 and test-4 are data nodes,
test-1 and test-2 are non-data noded, but data seems to be stored in some
other way. What is the explanation of that?

Regards
Szymon Gwóźdź


(system) #3